summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarco442018-09-12 07:35:44 +0200
committermarco442018-09-12 07:35:44 +0200
commite3ab1088bbf732953f8505be56a0c3de0ea9239e (patch)
treea963b20295af05e3844449dffbe69021e5f225da
parent880a7d67731eadb692cd3b21eb63468916e7db60 (diff)
downloadaur-e3ab1088bbf732953f8505be56a0c3de0ea9239e.tar.gz
Bump to 1.0.2 and patch missing header file
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--qbuttongroup.patch13
3 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49d71ceb538b..0d4aee541276 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = algobox
pkgdesc = Algorithmic learning for high school students
- pkgver = 0.9
- pkgrel = 2
+ pkgver = 1.0.2
+ pkgrel = 1
url = http://www.xm1math.net/algobox/index.html
arch = x86_64
arch = i686
license = GPLv2
depends = qt5-base
depends = qt5-webkit
- source = http://www.xm1math.net/algobox/algobox-0.9.tar.bz2
- md5sums = b8d57286e6838c5ec4ef2aa416bd2cb1
+ source = http://www.xm1math.net/algobox/algobox-1.0.2.tar.bz2
+ md5sums = c89783eaf926e67b570d37f87ab94c05
pkgname = algobox
diff --git a/PKGBUILD b/PKGBUILD
index 03e3fec62530..9541b64f5d25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Marc Cousin <cousinmarc@gmail.com>
pkgname=algobox
-pkgver=0.9
-pkgrel=2
+pkgver=1.0.2
+pkgrel=1
pkgdesc="Algorithmic learning for high school students"
url="http://www.xm1math.net/algobox/index.html"
arch=('x86_64' 'i686')
@@ -11,11 +11,16 @@ optdepends=()
makedepends=()
source=("http://www.xm1math.net/algobox/${pkgname}-${pkgver}.tar.bz2"
)
-md5sums=('b8d57286e6838c5ec4ef2aa416bd2cb1')
+md5sums=('c89783eaf926e67b570d37f87ab94c05')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/../qbuttongroup.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- qmake
+ qmake
make
}
diff --git a/qbuttongroup.patch b/qbuttongroup.patch
new file mode 100644
index 000000000000..0e1013e41e8a
--- /dev/null
+++ b/qbuttongroup.patch
@@ -0,0 +1,13 @@
+diff -r -c algobox-1.0.2-orig/algobox.cpp algobox-1.0.2/algobox.cpp
+*** algobox-1.0.2-orig/algobox.cpp 2017-08-08 17:20:13.000000000 +0200
+--- algobox-1.0.2/algobox.cpp 2018-09-12 07:31:31.692412191 +0200
+***************
+*** 67,72 ****
+--- 67,73 ----
+ #include <QTextDocumentWriter>
+ #include <QTextCharFormat>
+ #include <QAbstractItemModel>
++ #include <QButtonGroup>
+
+ #define STRINGIFY_INTERNAL(x) #x
+ #define STRINGIFY(x) STRINGIFY_INTERNAL(x)