summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2021-11-25 20:29:14 +0100
committerGiovanni Harting2021-11-25 20:29:14 +0100
commit807d7263ac743e03f28b19e94ad3f14ac65cc78a (patch)
treec6866bc9ae19bffc8c4224ee1dce6cbd9bc78cc6
downloadaur-807d7263ac743e03f28b19e94ad3f14ac65cc78a.tar.gz
Initial upload: alhp-keyring 20211125-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--alhp-keyring.install12
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1baaad57b06a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = alhp-keyring
+ pkgdesc = ALHP PGP keyring
+ pkgver = 20211125
+ pkgrel = 1
+ url = https://git.harting.dev/anonfunc/alhp-keyring
+ install = alhp-keyring.install
+ arch = any
+ license = GPL
+ source = https://f.harting.dev/alhp-keyring/alhp-keyring-20211125.tar.gz
+ source = https://f.harting.dev/alhp-keyring/alhp-keyring-20211125.tar.gz.sig
+ validpgpkeys = 2E3B2B05A332A7DB9019797848998B4039BED1CA
+ b2sums = 39fd6edd9b509c1520085d30cd56ad7459ad25df9e68a26ed014d3798436a87626c21250009860d0fdaa91c051cf7b1e53418cd93140b28471cbc5c516b6e5df
+ b2sums = SKIP
+
+pkgname = alhp-keyring
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39cd890f71ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Giovanni Harting <539@idlegandalf.com>
+
+pkgname=alhp-keyring
+pkgver=20211125
+pkgrel=1
+pkgdesc='ALHP PGP keyring'
+arch=(any)
+url='https://git.harting.dev/anonfunc/alhp-keyring'
+license=(GPL)
+install=$pkgname.install
+source=(https://f.harting.dev/$pkgname/${pkgname}-${pkgver}.tar.gz{,.sig})
+b2sums=('39fd6edd9b509c1520085d30cd56ad7459ad25df9e68a26ed014d3798436a87626c21250009860d0fdaa91c051cf7b1e53418cd93140b28471cbc5c516b6e5df'
+ 'SKIP')
+validpgpkeys=('2E3B2B05A332A7DB9019797848998B4039BED1CA') # Giovanni Harting <g.harting@mailstash.org>
+
+package() {
+ cd $pkgname-$pkgver
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
diff --git a/alhp-keyring.install b/alhp-keyring.install
new file mode 100644
index 000000000000..85f79f1f1718
--- /dev/null
+++ b/alhp-keyring.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ if usr/bin/pacman-key -l >/dev/null 2>&1; then
+ usr/bin/pacman-key --populate alhp
+ usr/bin/pacman-key --updatedb
+ fi
+}
+
+post_install() {
+ if [ -x usr/bin/pacman-key ]; then
+ post_upgrade
+ fi
+}