summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Wilken2021-06-29 15:43:41 +0200
committerTimo Wilken2021-06-29 15:43:41 +0200
commit10205e0880c5c64ae2258bbdc25b1d92ba0da854 (patch)
tree943b7fe47d4d876aaef0874c9b9113f222356289
parent038eadbd4a43c91abfcbb5d6bbde5abf92f4dfc3 (diff)
downloadaur-10205e0880c5c64ae2258bbdc25b1d92ba0da854.tar.gz
Embed real version number
This makes `aliBuild version` work properly.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 330ace002b91..f5f8441fb322 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alibuild
pkgdesc = A simple build tool for ALICE software at CERN
pkgver = 1.8.6
- pkgrel = 1
+ pkgrel = 2
url = https://alisw.github.io/alibuild/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9e0961f0f908..ddbf64495faa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
pkgname=alibuild
pkgver=1.8.6
-pkgrel=1
+pkgrel=2
pkgdesc='A simple build tool for ALICE software at CERN'
arch=(i686 x86_64)
url='https://alisw.github.io/alibuild/'
@@ -11,6 +11,11 @@ optdepends=('s3cmd: for the S3 remote store')
source=("https://github.com/alisw/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('c63cd5655fafb9397ba112940b920d428e1a374379727a56ca8612c8a89e03c1')
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i "s/LAST_TAG/$pkgver/g" setup.py
+}
+
check() {
cd "$srcdir/$pkgname-$pkgver"
python -m unittest discover tests