summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Wilken2021-07-03 18:34:51 +0200
committerTimo Wilken2021-07-03 18:53:58 +0200
commit207ee36b34a69570abe123e5c801e9b8f3445df7 (patch)
tree5f0b909d6330887f58255f55c5706a0edbfc071f
parent10205e0880c5c64ae2258bbdc25b1d92ba0da854 (diff)
downloadaur-207ee36b34a69570abe123e5c801e9b8f3445df7.tar.gz
Add dependencies needed for external commands
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD15
2 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5f8441fb322..e82ef700128c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,28 @@
pkgbase = alibuild
pkgdesc = A simple build tool for ALICE software at CERN
pkgver = 1.8.6
- pkgrel = 2
+ pkgrel = 3
url = https://alisw.github.io/alibuild/
arch = i686
arch = x86_64
license = GPL3
+ depends = coreutils
+ depends = util-linux
+ depends = bash
+ depends = tar
+ depends = gzip
+ depends = git
depends = python
depends = python-requests
depends = python-yaml
depends = python-distro
- depends = git
- optdepends = s3cmd: for the S3 remote store
+ optdepends = pigz: alternative, faster gzip implementation
+ optdepends = rsync: support for rsync remote stores
+ optdepends = docker: for building inside Docker containers
+ optdepends = s3cmd: support for remote stores on S3
+ optdepends = curl: support for remote stores on S3
+ optdepends = findutils: support for remote stores on S3
+ optdepends = awk: support for remote stores on S3
source = https://github.com/alisw/alibuild/archive/refs/tags/v1.8.6.tar.gz
sha256sums = c63cd5655fafb9397ba112940b920d428e1a374379727a56ca8612c8a89e03c1
diff --git a/PKGBUILD b/PKGBUILD
index ddbf64495faa..34f44182621d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,22 @@
# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
pkgname=alibuild
pkgver=1.8.6
-pkgrel=2
+pkgrel=3
pkgdesc='A simple build tool for ALICE software at CERN'
arch=(i686 x86_64)
url='https://alisw.github.io/alibuild/'
license=(GPL3)
-depends=(python python-requests python-yaml python-distro git)
-optdepends=('s3cmd: for the S3 remote store')
+# coreutils: ln mkdir df uname env
+# util-linux: mount
+# In theory, gzip is optional if we have pigz, but that's complicated for a PKGBUILD.
+depends=(coreutils util-linux bash tar gzip git python python-requests python-yaml python-distro)
+optdepends=('pigz: alternative, faster gzip implementation'
+ 'rsync: support for rsync remote stores'
+ 'docker: for building inside Docker containers'
+ 's3cmd: support for remote stores on S3'
+ 'curl: support for remote stores on S3'
+ 'findutils: support for remote stores on S3'
+ 'awk: support for remote stores on S3')
source=("https://github.com/alisw/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('c63cd5655fafb9397ba112940b920d428e1a374379727a56ca8612c8a89e03c1')