summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Wilken2021-05-07 20:20:51 +0200
committerTimo Wilken2021-05-07 20:22:03 +0200
commitf851b856914c27cb4dd72edbb778c8b77111b22a (patch)
treef29d9edc090dba9e9a23919d1e8003b1ed3303ea
parent127c78fb5bcdaf7624c177141dc857a75037dfaf (diff)
downloadaur-f851b856914c27cb4dd72edbb778c8b77111b22a.tar.gz
Upstream version v1.8.3.rc1
Not tagged as prerelease and should be fine for general consumption. With this release, we can run the unit tests on Arch as well. Adding git as a dependency as it's needed for actually running any builds.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c97f153a39f1..f3088007a441 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alibuild
pkgdesc = A simple build tool for ALICE software at CERN
- pkgver = 1.8.2
+ pkgver = 1.8.3.rc1
pkgrel = 1
url = https://alisw.github.io/alibuild/
arch = i686
@@ -10,9 +10,10 @@ pkgbase = alibuild
depends = python-requests
depends = python-yaml
depends = python-distro
+ depends = git
optdepends = s3cmd: for the S3 remote store
- source = https://github.com/alisw/alibuild/archive/refs/tags/v1.8.2.tar.gz
- sha256sums = 9e053de1d6cdfa153d008baf9b4da2623d2950fc68222783788ce5c9c089349b
+ source = https://github.com/alisw/alibuild/archive/refs/tags/v1.8.3.rc1.tar.gz
+ sha256sums = 011e99bc8674978e806c9fbb5c9866347e406ce3a7ec4b4fb9d4795652fbadfa
pkgname = alibuild
diff --git a/PKGBUILD b/PKGBUILD
index e484fd2baa3b..a719fc0550d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
pkgname=alibuild
-pkgver=1.8.2
+pkgver=1.8.3.rc1
pkgrel=1
pkgdesc='A simple build tool for ALICE software at CERN'
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url='https://alisw.github.io/alibuild/'
-license=('GPL3')
-depends=('python' 'python-requests' 'python-yaml' 'python-distro')
+license=(GPL3)
+depends=(python python-requests python-yaml python-distro git)
optdepends=('s3cmd: for the S3 remote store')
source=("https://github.com/alisw/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('9e053de1d6cdfa153d008baf9b4da2623d2950fc68222783788ce5c9c089349b')
+sha256sums=('011e99bc8674978e806c9fbb5c9866347e406ce3a7ec4b4fb9d4795652fbadfa')
check() {
cd "$srcdir/$pkgname-$pkgver"
- # Tests are currently broken on Arch because we need --force-unknown-architecture.
- #python -m unittest discover tests
+ python -m unittest discover tests
}
package() {