summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Wilken2021-05-03 19:32:24 +0200
committerTimo Wilken2021-05-03 19:32:24 +0200
commitfe4e435a8e4f29e1b2a4e1fa285ceedf05e838eb (patch)
treec2a6df31954ce3eadfb6fd218aca549dc511236d
downloadaur-fe4e435a8e4f29e1b2a4e1fa285ceedf05e838eb.tar.gz
Initialise with upstream version v1.8.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ecaef158525
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = alibuild
+ pkgdesc = A simple build tool for ALICE software at CERN
+ pkgver = 1.8.2
+ pkgrel = 1
+ url = https://alisw.github.io/alibuild/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = python-requests
+ depends = python-yaml
+ depends = python-distro
+ optdepends = s3cmd: for the S3 remote store
+ source = https://alisw.github.io/alibuild//archive/refs/tags/v1.8.2.tar.gz
+ sha256sums = 9e053de1d6cdfa153d008baf9b4da2623d2950fc68222783788ce5c9c089349b
+
+pkgname = alibuild
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c54262142e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
+pkgname=alibuild
+pkgver=1.8.2
+pkgrel=1
+pkgdesc='A simple build tool for ALICE software at CERN'
+arch=('i686' 'x86_64')
+url='https://alisw.github.io/alibuild/'
+license=('GPL3')
+depends=('python' 'python-requests' 'python-yaml' 'python-distro')
+optdepends=('s3cmd: for the S3 remote store')
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('9e053de1d6cdfa153d008baf9b4da2623d2950fc68222783788ce5c9c089349b')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # Tests are currently broken on Arch because we need --force-unknown-architecture.
+ #python -m unittest discover tests
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: