summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-08 00:36:36 +0200
committerDimitris Kiziridis2020-03-08 00:36:36 +0200
commitfc8c6153bd339e734932515002221006f72aacf0 (patch)
tree8fc02a1dad6b2b8f2fffa89122ff03f694c4eb1f
downloadaur-fc8c6153bd339e734932515002221006f72aacf0.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8bce6d4347d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = alice-bin
+ pkgdesc = An educational software that teaches students computer programming in a 3D environment
+ pkgver = 3.5
+ pkgrel = 1
+ url = http://www.alice.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-environment
+ depends = mesa
+ provides = alice3
+ noextract = Alice3_unix_3_5.sh
+ source = http://www.alice.org/wp-content/uploads/2019/04/Alice3_unix_3_5.sh
+ sha512sums = 8c1d17e95bc08b38a9615607be9c47dc96c0e374118364377a197e12026e6b26a0058e75a4f7d0f9c81ad1153734012a6796eaa44247c00d19c8e4a114f0c836
+
+pkgname = alice-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..642e0ee27011
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: William Grieshaber <me@zee.li>
+# Contributor: Chris Giles <Chris.G.27 (at) Gmail.com>
+# Contributor: Nathan Owe <ndowens.aur at gmail dot com>
+
+pkgname=alice-bin
+pkgver=3.5
+pkgrel=1
+pkgdesc='An educational software that teaches students computer programming in a 3D environment'
+arch=('i686' 'x86_64')
+url="http://www.alice.org/"
+license=('custom')
+depends=('java-environment' 'mesa')
+provides=('alice3')
+source=("http://www.alice.org/wp-content/uploads/2019/04/Alice3_unix_3_5.sh")
+noextract=('Alice3_unix_3_5.sh')
+sha512sums=('8c1d17e95bc08b38a9615607be9c47dc96c0e374118364377a197e12026e6b26a0058e75a4f7d0f9c81ad1153734012a6796eaa44247c00d19c8e4a114f0c836')
+
+package()
+{
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}"/opt
+ mkdir -p "${pkgdir}"/usr/share/applications
+ chmod 755 Alice3_unix_3_5.sh
+ ./Alice3_unix_3_5.sh -q -dir "$pkgdir"/opt/alice
+ mv "$pkgdir/opt/alice/Alice 3.desktop" "${pkgdir}"/usr/share/applications/alice3.desktop
+ rm "$pkgdir/opt/alice/uninstall"
+ sed -i "s@${pkgdir}@@" "${pkgdir}/usr/share/applications/alice3.desktop"
+ sed -i "6s@.*@Icon=alice3@" "${pkgdir}/usr/share/applications/alice3.desktop"
+ sed -i "7s@.*@Categories=Application;Development;@" "${pkgdir}/usr/share/applications/alice3.desktop"
+ sed -i "3 a Comment=An IDE for teaching kids programming" "${pkgdir}/usr/share/applications/alice3.desktop"
+ install -Dm644 "${pkgdir}/opt/alice/.install4j/Alice 3.png" "${pkgdir}/usr/share/pixmaps/alice3.png"
+ install -Dm644 "${pkgdir}/opt/alice/application/EULA_Alice3.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file