summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-08-31 12:59:04 +0200
committerbartus2018-08-31 12:59:04 +0200
commit27306d31be3b22858b367a1362970130d6a97caa (patch)
treeaaf393045a4a206334203d065f797fa9a2272d75
parentc5d8fb1ad924f436053262d8560f030f68451919 (diff)
downloadaur-27306d31be3b22858b367a1362970130d6a97caa.tar.gz
switch to release tarball
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
-rw-r--r--submodule.patch19
3 files changed, 48 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2980618ab885..7ba166ccd48c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alice-vision
pkgdesc = Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms
- pkgver = 1.0.r707.g4e0a3a99
- pkgrel = 1
+ pkgver = 2.0.0
+ pkgrel = 2
url = http://alicevision.github.io/
arch = i686
arch = x86_64
@@ -28,14 +28,20 @@ pkgbase = alice-vision
depends = coin-or-lemon
depends = coin-or-osi
depends = google-glog
- source = alice-vision::git+https://github.com/alicevision/AliceVision.git#branch=develop
- source = osi_clp::git+https://github.com/alicevision/osi_clp.git
+ provides = alice-vision
+ conflicts = alice-vision-git
+ source = https://github.com/alicevision/AliceVision/archive/v2.0.0.tar.gz
source = ute_lib::git+https://github.com/alicevision/uncertaintyTE.git
source = geogram::git+https://github.com/alicevision/geogram.git
+ source = MeshSDFilter::git+https://github.com/alicevision/MeshSDFilter.git#branch=av_develop
+ source = nanoflann::git+https://github.com/alicevision/nanoflann.git
+ source = submodule.patch
+ md5sums = 1ff20994f1ff259850c3e170ef451634
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = eb62c8be5a0d7ce537a928314c9d0028
pkgname = alice-vision
diff --git a/PKGBUILD b/PKGBUILD
index ef7e6373b52b..5972ecd9b2ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
_name=alice-vision
-#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
-_fragment="#branch=develop"
pkgname=${_name}
-pkgver=1.0.r707.g4e0a3a99
-pkgrel=1
+pkgver=2.0.0
+pkgrel=2
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
arch=('i686' 'x86_64')
url="http://alicevision.github.io/"
license=('MPL2' 'MIT')
groups=()
+conflicts=(alice-vision-git)
+provides=(alice-vision)
depends=('openblas-lapack' 'gflags' 'glfw-x11' 'alembic' 'boost-libs' 'openexr' 'openimageio' 'opengv-git' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-lemon' 'coin-or-osi' 'google-glog')
makedepends=('boost' 'eigen' 'ceres-solver' 'cuda' 'git' 'cmake' 'magma')
-source=("${pkgname}::git+https://github.com/alicevision/AliceVision.git${_fragment}"
- "osi_clp::git+https://github.com/alicevision/osi_clp.git"
+source=("https://github.com/alicevision/AliceVision/archive/v${pkgver}.tar.gz"
"ute_lib::git+https://github.com/alicevision/uncertaintyTE.git"
"geogram::git+https://github.com/alicevision/geogram.git"
+ "MeshSDFilter::git+https://github.com/alicevision/MeshSDFilter.git#branch=av_develop"
+ "nanoflann::git+https://github.com/alicevision/nanoflann.git"
+ "submodule.patch"
)
-md5sums=('SKIP'
+md5sums=('1ff20994f1ff259850c3e170ef451634'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'eb62c8be5a0d7ce537a928314c9d0028')
_CMAKE_FLAGS=(
-DCMAKE_INSTALL_PREFIX=/usr
@@ -37,17 +41,14 @@ _CMAKE_FLAGS=(
-DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc
)
-
-pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+_path="AliceVision-${pkgver}"
prepare() {
- cd ${srcdir}/${pkgname}
- git submodule init
- git config submodule.src/dependencies/osi_clp.url ${srcdir}/osi_clp
- git submodule update
+ cd ${srcdir}/${_path}
+ patch -Np1 -i ${srcdir}/submodule.patch
+ rmdir src/dependencies/{MeshSDFilter,nanoflann}
+ cp -r ${srcdir}/MeshSDFilter src/dependencies/MeshSDFilter
+ cp -r ${srcdir}/nanoflann src/dependencies/nanoflann
}
@@ -68,16 +69,9 @@ build() {
make DESTDIR="../geogram_bin" install
cd ..
-# msg2 "Build Osi library"
-# mkdir -p osi_build && cd osi_build
-# cmake -DCMAKE_INSTALL_PREFIX=/ ../osi_clp
-# make
-# make DESTDIR="../osi_bin" install
-# cd ..
-
msg2 "Build AliceVision library"
mkdir -p build && cd build
- cmake ${_CMAKE_FLAGS[@]} -DUNCERTAINTYTE_DIR=${srcdir}/ute_bin -DGEOGRAM_INSTALL_PREFIX=${srcdir}/geogram_bin ../${pkgname}
+ cmake ${_CMAKE_FLAGS[@]} -DUNCERTAINTYTE_DIR=${srcdir}/ute_bin -DGEOGRAM_INSTALL_PREFIX=${srcdir}/geogram_bin ../${_path}
make
}
diff --git a/submodule.patch b/submodule.patch
new file mode 100644
index 000000000000..6eefd18e0520
--- /dev/null
+++ b/submodule.patch
@@ -0,0 +1,19 @@
+diff -Naur orig/AliceVision-2.0.0/src/CMakeLists.txt AliceVision-2.0.0/src/CMakeLists.txt
+--- orig/AliceVision-2.0.0/src/CMakeLists.txt 2018-08-09 15:35:45.000000000 +0200
++++ AliceVision-2.0.0/src/CMakeLists.txt 2018-08-31 09:30:39.637939620 +0200
+@@ -142,15 +142,6 @@
+ endmacro(add_target_properties)
+
+ # ==============================================================================
+-# Check that submodule have been initialized and updated
+-# ==============================================================================
+-if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/dependencies/osi_clp/CoinUtils)
+- message(FATAL_ERROR
+- "\n submodule(s) are missing, please update your repository:\n"
+- " > git submodule update -i\n")
+-endif()
+-
+-# ==============================================================================
+ # Additional cmake find modules
+ # ==============================================================================
+ set(CMAKE_MODULE_PATH