summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-08-29 00:18:24 +0200
committerbartus2019-08-29 00:18:24 +0200
commit843a99308ca4bd33794b6774b10bbd240a717cc4 (patch)
tree9c3eab37afe816ae14aa5dea27156727a4c5a7d3
parent4d06c48bb2c57480a7cc103ae07d7407df5cadf2 (diff)
downloadaur-843a99308ca4bd33794b6774b10bbd240a717cc4.tar.gz
Add popsift
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6f3a6c3f27f..6f363b6b7786 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ license=('MPL2' 'MIT')
groups=()
conflicts=(alice-vision-git)
provides=(alice-vision)
-# split: uncertaintyTE, geogram, popsift, cctag
+# split: uncertaintyTE, geogram, cctag
depends=('gflags' 'glfw-x11' 'alembic' 'boost-libs' 'openexr' 'openimageio' 'opengv-git' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-lemon' 'coin-or-osi' 'google-glog' 'freetype2' 'zlib' 'libtiff' 'libjpeg' 'libpng' 'libraw' 'opencv' 'lapack' 'suitesparse')
makedepends=('boost' 'eigen' 'ceres-solver' 'git' 'cmake')
source=("https://github.com/alicevision/AliceVision/archive/v${pkgver}.tar.gz"
@@ -41,8 +41,9 @@ _CMAKE_FLAGS=(
((DISABLE_CUDA)) && { _CMAKE_FLAGS+=('-DALICEVISION_USE_CUDA=OFF')
DISABLE_UTE=1 # Disable uncertaintyTE as it also depends on cuda
- } || { makedepends+=('cuda')
- _CMAKE_FLAGS+=('-DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc')
+ } || { makedepends+=('cuda' 'popsift')
+ _CMAKE_FLAGS+=( -DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc )
+ _CMAKE_FLAGS+=( -DPopSift_DIR=/usr )
}
((DISABLE_UTE)) || { source+=("ute_lib::git+https://github.com/alicevision/uncertaintyTE.git")