summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-10-23 00:04:29 +0200
committerbartus2019-10-23 00:07:56 +0200
commit96110472577b8ff7c7273f6ddc10d572865d92b7 (patch)
treefdde56b6ba61104fb5703d557d2d7f5a8b6e1823
parent48ba0bf6fdd1eb6bd99e14cac86f6976f689dfc2 (diff)
downloadaur-96110472577b8ff7c7273f6ddc10d572865d92b7.tar.gz
Fix boost-1.71 log
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb785285c46b..b38f4cee492d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,19 +22,18 @@ pkgbase = alice-vision
depends = opengv
depends = coin-or-clp
depends = ceres-solver
- optdepends = popsift-libs: for GPU accelerated feature matching
- optdepends = uncertainty-framework: for SFM uncertainty estimation
- optdepends = cuda: (libcudart.so) for depth map computation
provides = alice-vision
conflicts = alice-vision-git
source = https://github.com/alicevision/AliceVision/archive/v2.2.0.tar.gz
source = MeshSDFilter::git+https://github.com/alicevision/MeshSDFilter.git#branch=av_develop
source = nanoflann::git+https://github.com/alicevision/nanoflann.git
source = submodule.patch
+ source = https://github.com/alicevision/AliceVision/pull/709.patch
sha256sums = 157d06d472ffef29f08a781c9df82daa570a49bb009e56a2924a3bd2f555ef50
sha256sums = SKIP
sha256sums = SKIP
sha256sums = ddbe76933cea0300b577095afa7459113a2d2ef02d4f300424261165ad9dee22
+ sha256sums = 3055e98b7d788135d9873bc7fc4698cb72a3f8212155f281877e37d315a693d8
pkgname = alice-vision
diff --git a/PKGBUILD b/PKGBUILD
index d3cda632688e..610538a14213 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,11 +24,13 @@ source=("https://github.com/alicevision/AliceVision/archive/v${pkgver}.tar.gz"
"MeshSDFilter::git+https://github.com/alicevision/MeshSDFilter.git#branch=av_develop"
"nanoflann::git+https://github.com/alicevision/nanoflann.git"
"submodule.patch"
+ "https://github.com/alicevision/AliceVision/pull/709.patch"
)
sha256sums=('157d06d472ffef29f08a781c9df82daa570a49bb009e56a2924a3bd2f555ef50'
'SKIP'
'SKIP'
- 'ddbe76933cea0300b577095afa7459113a2d2ef02d4f300424261165ad9dee22')
+ 'ddbe76933cea0300b577095afa7459113a2d2ef02d4f300424261165ad9dee22'
+ '3055e98b7d788135d9873bc7fc4698cb72a3f8212155f281877e37d315a693d8')
_CMAKE_FLAGS=(
-DCMAKE_INSTALL_PREFIX=/usr
@@ -71,6 +73,7 @@ _path="AliceVision-${pkgver}"
prepare() {
cd ${srcdir}/${_path}
patch -Np1 -i ${srcdir}/submodule.patch
+ patch -Np1 -i ${srcdir}/709.patch
rm -rf src/dependencies/{MeshSDFilter,nanoflann}
cp -r ${srcdir}/MeshSDFilter src/dependencies/MeshSDFilter
cp -r ${srcdir}/nanoflann src/dependencies/nanoflann