summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-08-06 17:48:12 +0200
committerbartus2018-08-06 17:48:12 +0200
commitc5d8fb1ad924f436053262d8560f030f68451919 (patch)
tree57e353d031f7a55990d49cc60fe88fc1cfd2d3e5
parent1b11c1e7c298a1bed479b8ffa45dfd89bbbbf663 (diff)
downloadaur-c5d8fb1ad924f436053262d8560f030f68451919.tar.gz
remove upstream applied patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--sfmdata.patch22
3 files changed, 3 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e061cd901e70..2980618ab885 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alice-vision
pkgdesc = Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms
- pkgver = 1.0.r705.g8e907639
+ pkgver = 1.0.r707.g4e0a3a99
pkgrel = 1
url = http://alicevision.github.io/
arch = i686
@@ -32,12 +32,10 @@ pkgbase = alice-vision
source = osi_clp::git+https://github.com/alicevision/osi_clp.git
source = ute_lib::git+https://github.com/alicevision/uncertaintyTE.git
source = geogram::git+https://github.com/alicevision/geogram.git
- source = sfmdata.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = a96ca3a7c1bce6dee90bfc2c05f42103
pkgname = alice-vision
diff --git a/PKGBUILD b/PKGBUILD
index d92678accae7..ef7e6373b52b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name=alice-vision
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
_fragment="#branch=develop"
pkgname=${_name}
-pkgver=1.0.r705.g8e907639
+pkgver=1.0.r707.g4e0a3a99
pkgrel=1
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
arch=('i686' 'x86_64')
@@ -17,13 +17,11 @@ source=("${pkgname}::git+https://github.com/alicevision/AliceVision.git${_fragme
"osi_clp::git+https://github.com/alicevision/osi_clp.git"
"ute_lib::git+https://github.com/alicevision/uncertaintyTE.git"
"geogram::git+https://github.com/alicevision/geogram.git"
- "sfmdata.patch"
)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'a96ca3a7c1bce6dee90bfc2c05f42103')
+ 'SKIP')
_CMAKE_FLAGS=(
-DCMAKE_INSTALL_PREFIX=/usr
@@ -50,7 +48,6 @@ prepare() {
git submodule init
git config submodule.src/dependencies/osi_clp.url ${srcdir}/osi_clp
git submodule update
- git apply ${srcdir}/sfmdata.patch
}
diff --git a/sfmdata.patch b/sfmdata.patch
deleted file mode 100644
index ee95f7cdf661..000000000000
--- a/sfmdata.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/src/software/utils/main_computeUncertainty.cpp b/src/software/utils/main_computeUncertainty.cpp
-index 6574cba1..5596b934 100644
---- a/src/software/utils/main_computeUncertainty.cpp
-+++ b/src/software/utils/main_computeUncertainty.cpp
-@@ -5,6 +5,8 @@
-
- #include <aliceVision/sfm/sfm.hpp>
- #include <aliceVision/sfm/BundleAdjustmentCeres.hpp>
-+#include <aliceVision/sfmData/SfMData.hpp>
-+#include <aliceVision/sfmDataIO/sfmDataIO.hpp>
- #include <aliceVision/system/cmdline.hpp>
- #include <aliceVision/config.hpp>
-
-@@ -24,6 +26,8 @@
-
- using namespace aliceVision;
- using namespace aliceVision::sfm;
-+using namespace aliceVision::sfmData;
-+using namespace aliceVision::sfmDataIO;
- namespace po = boost::program_options;
-
-