summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-08-05 17:58:50 +0200
committerbartus2018-08-05 17:58:50 +0200
commitd92732f4a7c80d835a737610cca58687d0a65033 (patch)
treee6df730b107d00dda0030e3379abc2ec62c2e521
parent4b6f675e6d360a31cef6e1e767c7b8deb7b5c6d3 (diff)
downloadaur-d92732f4a7c80d835a737610cca58687d0a65033.tar.gz
remove upstream applied patches
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--cmake_magma.patch20
-rw-r--r--cmake_ute.patch13
-rw-r--r--missing_define.patch16
5 files changed, 3 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc99c0b243a2..bde8df30a7c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alice-vision
pkgdesc = Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms
- pkgver = 1.0.r669.g610d1004
+ pkgver = 1.0.r692.gf57dfb28
pkgrel = 1
url = http://alicevision.github.io/
arch = i686
@@ -32,16 +32,10 @@ pkgbase = alice-vision
source = osi_clp::git+https://github.com/alicevision/osi_clp.git
source = ute_lib::git+https://github.com/alicevision/uncertaintyTE.git
source = geogram::git+https://github.com/alicevision/geogram.git
- source = cmake_magma.patch
- source = missing_define.patch
- source = cmake_ute.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 470da1a79a22ffea8d2c0b6a34abc9e9
- md5sums = ade01150d6237a52bd62b61ae792398d
- md5sums = 15a8861c625d80b274282df9791b57a9
pkgname = alice-vision
diff --git a/PKGBUILD b/PKGBUILD
index 3041c2877e58..637a4bd59fae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name=alice-vision
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
_fragment="#branch=develop"
pkgname=${_name}
-pkgver=1.0.r669.g610d1004
+pkgver=1.0.r692.gf57dfb28
pkgrel=1
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
arch=('i686' 'x86_64')
@@ -17,17 +17,11 @@ source=("${pkgname}::git+https://github.com/alicevision/AliceVision.git${_fragme
"osi_clp::git+https://github.com/alicevision/osi_clp.git"
"ute_lib::git+https://github.com/alicevision/uncertaintyTE.git"
"geogram::git+https://github.com/alicevision/geogram.git"
- "cmake_magma.patch"
- "missing_define.patch"
- "cmake_ute.patch"
)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '470da1a79a22ffea8d2c0b6a34abc9e9'
- 'ade01150d6237a52bd62b61ae792398d'
- '15a8861c625d80b274282df9791b57a9')
+ 'SKIP')
_CMAKE_FLAGS=(
-DCMAKE_INSTALL_PREFIX=/usr
@@ -54,9 +48,6 @@ prepare() {
git submodule init
git config submodule.src/dependencies/osi_clp.url ${srcdir}/osi_clp
git submodule update
- git apply ../cmake_magma.patch
- git apply ../missing_define.patch
- git apply ../cmake_ute.patch
}
diff --git a/cmake_magma.patch b/cmake_magma.patch
deleted file mode 100644
index e964cfd03284..000000000000
--- a/cmake_magma.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/src/cmake/FindMAGMA.cmake b/src/cmake/FindMAGMA.cmake
-index 51cd4b30..3f5fc72d 100644
---- a/src/cmake/FindMAGMA.cmake
-+++ b/src/cmake/FindMAGMA.cmake
-@@ -17,6 +17,8 @@
- #If environment variable MAGMA_ROOT is specified, it has same effect as MAGMA_ROOT
- if( NOT MAGMA_ROOT AND NOT $ENV{MAGMA_ROOT} STREQUAL "" )
- set( MAGMA_ROOT $ENV{MAGMA_ROOT} )
-+endif()
-+if(MAGMA_ROOT)
- # set library directories
- set(MAGMA_LIBRARY_DIRS ${MAGMA_ROOT}/lib)
- # set include directories
-@@ -32,4 +34,4 @@ if( NOT MAGMA_ROOT AND NOT $ENV{MAGMA_ROOT} STREQUAL "" )
- set(MAGMA_FOUND TRUE)
- else()
- set(MAGMA_FOUND FALSE)
--endif()
-\ No newline at end of file
-+endif()
diff --git a/cmake_ute.patch b/cmake_ute.patch
deleted file mode 100644
index 4dddb243179a..000000000000
--- a/cmake_ute.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/cmake/FindUncertaintyTE.cmake b/src/cmake/FindUncertaintyTE.cmake
-index 187dd506..9e20bf52 100644
---- a/src/cmake/FindUncertaintyTE.cmake
-+++ b/src/cmake/FindUncertaintyTE.cmake
-@@ -23,7 +23,7 @@ FIND_PATH(UNCERTAINTYTE_INCLUDE_DIR uncertaintyTE/uncertainty.h
- include
- )
-
--FIND_LIBRARY(UNCERTAINTYTE_LIBRARY NAMES uncertainty_shared
-+FIND_LIBRARY(UNCERTAINTYTE_LIBRARY NAMES uncertainty_shared uncertaintyTE
- HINTS
- $ENV{UNCERTAINTYTE_DIR}
- ${UNCERTAINTYTE_DIR}
diff --git a/missing_define.patch b/missing_define.patch
deleted file mode 100644
index 964e39cfad2b..000000000000
--- a/missing_define.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/src/software/utils/main_computeUncertainty.cpp b/src/software/utils/main_computeUncertainty.cpp
-index f6864e6a..6574cba1 100644
---- a/src/software/utils/main_computeUncertainty.cpp
-+++ b/src/software/utils/main_computeUncertainty.cpp
-@@ -17,6 +17,11 @@
- #include <sstream>
- #include <vector>
-
-+// These constants define the current software version.
-+// They must be updated when the command line is changed.
-+#define ALICEVISION_SOFTWARE_VERSION_MAJOR 1
-+#define ALICEVISION_SOFTWARE_VERSION_MINOR 0
-+
- using namespace aliceVision;
- using namespace aliceVision::sfm;
- namespace po = boost::program_options;