summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-09-14 23:31:59 +0200
committerbartus2019-09-14 23:31:59 +0200
commit35a5549a6dd0024e4b41d6b786014d66210bfd8b (patch)
tree8b88e9887b7fe51b7267b4ae2e73ab414e334c6b
parent43fb31d33c8333bdd44c066a7c492f17249753a5 (diff)
downloadaur-35a5549a6dd0024e4b41d6b786014d66210bfd8b.tar.gz
Fix doc build.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26fab0f420de..8c4249843602 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = alice-vision-git
pkgdesc = Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms
pkgver = 2.2.0.r17.g63a3d6ad
- pkgrel = 1
+ pkgrel = 2
url = https://alicevision.github.io/
arch = i686
arch = x86_64
license = MPL2
license = MIT
makedepends = boost
+ makedepends = doxygen
+ makedepends = python-sphinx
makedepends = eigen
makedepends = ceres-solver
makedepends = cuda
diff --git a/PKGBUILD b/PKGBUILD
index b15d29b66718..238659b3dfcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _name=alice-vision
_fragment="#branch=develop"
pkgname=${_name}-git
pkgver=2.2.0.r17.g63a3d6ad
-pkgrel=1
+pkgrel=2
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
@@ -14,7 +14,7 @@ groups=()
conflicts=(alice-vision)
provides=(alice-vision)
depends=('openblas-lapack' 'gflags' 'glfw-x11' 'alembic' 'boost-libs' 'openexr' 'openimageio' 'opengv-git' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-lemon' 'coin-or-osi' 'google-glog')
-makedepends=('boost' 'eigen' 'ceres-solver' 'cuda' 'git' 'cmake' 'magma')
+makedepends=('boost' 'doxygen' 'python-sphinx' 'eigen' 'ceres-solver' 'cuda' 'git' 'cmake' 'magma')
source=("${pkgname}::git+https://github.com/alicevision/AliceVision.git${_fragment}"
"ute_lib::git+https://github.com/alicevision/uncertaintyTE.git"
"geogram::git+https://github.com/alicevision/geogram.git"
@@ -54,6 +54,8 @@ prepare() {
# git config submodule.src/dependencies/osi_clp.url
git submodule update
git apply ${srcdir}/submodule.patch
+# fix doc build
+ sed -i '/^ *install.*doc/s/doc/htmlDoc/' src/CMakeLists.txt
}