summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-05-23 00:13:31 +0200
committerbartus2020-05-23 00:13:31 +0200
commit6511e1103d17d52984e693820f0614c5a692365a (patch)
treea46b66e978466f3c903115270db10d4c6258d28a
parent658f31ae3c47393cb3dcee972eec1c9e015d87a5 (diff)
downloadaur-6511e1103d17d52984e693820f0614c5a692365a.tar.gz
Fix geogram: legacy_numeric won't build GCC:10.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3f962453c38..1f8ca2ef5a12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alice-vision-git
pkgdesc = Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms
- pkgver = 2.2.0.r299.gbb78c6e0a
+ pkgver = 2.2.0.r491.g88e626786
pkgrel = 1
url = https://alicevision.github.io/
arch = i686
@@ -20,11 +20,12 @@ pkgbase = alice-vision-git
makedepends = cmake
depends = alembic
depends = boost-libs
- depends = openimageio
- depends = flann
- depends = opengv
depends = coin-or-clp
+ depends = flann
depends = google-glog
+ depends = opencv
+ depends = openimageio
+ depends = opengv
depends = glu
depends = glfw-x11
depends = magma
diff --git a/PKGBUILD b/PKGBUILD
index b25aff48a019..a105d64b27b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _name=alice-vision
#_fragment="#commit=eebc3e4f"
_fragment="#branch=develop"
pkgname=${_name}-git
-pkgver=2.2.0.r299.gbb78c6e0a
+pkgver=2.2.0.r491.g88e626786
pkgrel=1
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ conflicts=("${_name}" geogram uncertainty-framework)
provides=("${_name}" geogram uncertainty-framework)
-depends=('alembic' 'boost-libs' 'openimageio' 'flann' 'opengv' 'coin-or-clp' 'google-glog')
+depends=( 'alembic' 'boost-libs' 'coin-or-clp' 'flann' 'google-glog' 'opencv' 'openimageio' 'opengv' )
depends+=('glu' 'glfw-x11') # geogram deps.
depends+=('magma' 'ceres-solver') # uncertaintyTE deps.
makedepends=('ninja' 'boost' 'eigen' 'freetype2' 'gflags' 'doxygen' 'python-sphinx' 'coin-or-coinutils' 'coin-or-lemon' 'git' 'cmake')
@@ -75,7 +75,7 @@ build() {
msg2 "Build geogram library"
mkdir -p geogram_build
- cmake -DCMAKE_INSTALL_PREFIX=/ -DGEOGRAM_LIB_ONLY=ON -DGEOGRAM_USE_SYSTEM_GLFW3=ON -DCMAKE_BUILD_TYPE:STRING=Release -DVORPALINE_PLATFORM:STRING=Linux64-gcc-dynamic -G Ninja -S geogram -B geogram_build
+ cmake -DCMAKE_INSTALL_PREFIX=/ -DGEOGRAM_LIB_ONLY=ON -DGEOGRAM_USE_SYSTEM_GLFW3=ON -DCMAKE_BUILD_TYPE:STRING=Release -DVORPALINE_PLATFORM:STRING=Linux64-gcc-dynamic -DGEOGRAM_WITH_LEGACY_NUMERICS=OFF -G Ninja -S geogram -B geogram_build
# shellcheck disable=SC2030,SC2031,SC2046 # ninja call won't work with shell substitution in quotes.
ninja $([ -v MAKEFLAGS ] || echo -j1) -C geogram_build
DESTDIR="${srcdir}/geogram_bin" ninja -C geogram_build install