summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Vandegriff2022-03-20 00:52:27 -0400
committerJohan Vandegriff2022-03-20 00:52:27 -0400
commit5d7aa06e603d53a6671342ccbeab91db15cc1df1 (patch)
treea0ca240371cf344b1a9dd06de6815fad13690f53
downloadaur-5d7aa06e603d53a6671342ccbeab91db15cc1df1.tar.gz
initial files
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4132490cb3be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = alice2-bin
+ pkgdesc = An educational software that teaches students computer programming in a 3D environment
+ pkgver = 2.4
+ pkgrel = 1
+ url = https://www.alice.org/get-alice/alice-2/
+ arch = x86_64
+ arch = i586
+ license = custom
+ depends = jdk8-openjdk
+ depends = java-runtime
+ depends = lib32-libglvnd
+ source = alice2-bin-2.4.tar::https://www.alice.org/wp-content/uploads/2017/05/Alice2_4e.tar
+ sha256sums = 5a087c75c7a1af95141791f0d4d5846e6067cec9ef5c89c3d67fe7af3b612040
+
+pkgname = alice2-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfa3108ea1e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Johan Vandegriff <johan at vandymail dot com>
+
+pkgname=alice2-bin
+pkgver=2.4
+_pkgver=2_4e
+pkgrel=1
+pkgdesc='An educational software that teaches students computer programming in a 3D environment'
+arch=('x86_64' 'i586') #NOTE: not tested on i586 but the "run-alice" script seems to indicate that it works
+url='https://www.alice.org/get-alice/alice-2/'
+license=('custom')
+depends=('jdk8-openjdk'
+ 'java-runtime'
+ 'lib32-libglvnd')
+source=("${pkgname}-${pkgver}.tar::https://www.alice.org/wp-content/uploads/2017/05/Alice${_pkgver}.tar")
+sha256sums=('5a087c75c7a1af95141791f0d4d5846e6067cec9ef5c89c3d67fe7af3b612040')
+
+package() {
+ install -d "${pkgdir}/usr/bin" "${pkgdir}/opt"
+ echo '#!/bin/sh
+export JAVA_HOME=/usr/lib/jvm/java-8-openjdk
+cd /opt/alice2/Required/
+./run-alice
+' > alice2
+ install -Dm755 alice2 -t "${pkgdir}/usr/bin"
+ mkdir -p "Alice 2.4/Required/jython-2.1/cachedir/packages"
+ cp -avR "Alice 2.4" "${pkgdir}/opt/alice2"
+ chmod -R 755 "${pkgdir}/opt/alice2"
+ #chmod 755 "${pkgdir}/opt/alice2/Required/run-alice"
+ install -Dm644 "Alice 2.4/Required/Alice2.4_LICENSE.pdf" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}