summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Lagnese2021-03-24 22:52:57 -0700
committerTim Lagnese2021-03-24 22:58:59 -0700
commitaf6b986677cd30e105e44f69cd4258d45a13ec2a (patch)
tree51af175159be396969623478226015e0819a4be8
parentb8f16cc5a24cfbf552babc254147e99ddbc5994a (diff)
downloadaur-af6b986677cd30e105e44f69cd4258d45a13ec2a.tar.gz
Update to v1.0.0
* Use the release tarball for alire v1.0.0 allowing checksumming * Changed md5sums to b2. Why not, right? * More closely follow https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git_submodules
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD33
2 files changed, 32 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b4f8c373fce..f04528b0d768 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alire
pkgdesc = A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam.
- pkgver = 0.7.1
+ pkgver = 1.0.0
pkgrel = 1
url = https://alire.ada.dev/
arch = i686
@@ -9,7 +9,7 @@ pkgbase = alire
makedepends = git
makedepends = gprbuild
depends = glibc
- source = git+https://github.com/alire-project/alire.git#tag=v0.7.1
+ source = https://github.com/alire-project/alire/archive/refs/tags/v1.0.0.tar.gz
source = git+https://github.com/alire-project/xmlezout.git
source = git+https://github.com/mosteo/ajunitgen.git
source = git+https://github.com/mosteo/aaa.git
@@ -22,19 +22,19 @@ pkgbase = alire
source = git+https://github.com/mosteo/uri-ada.git
source = git+https://github.com/mosteo/minirest
source = git+https://github.com/Fabien-Chouteau/spdx_ada#commit=319ca7bcc1e2eb1843aad1f64aca3ecba91a2bcc
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ b2sums = bad08a570d464d454739edb42717a5ad33eb132dea4c3f2752e26bf122aa6a6b058e1b89987a9c8a6c5d432492b29586fbefad0e54207f8e7a9601ef1bbba9a0
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = alire
diff --git a/PKGBUILD b/PKGBUILD
index 00520a99341b..e6006f872e1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tim Lagnese <tim at inept tech>
pkgname=alire
-pkgver=0.7.1
+pkgver=1.0.0
pkgrel=1
pkgdesc="A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam."
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://alire.ada.dev/"
license=(GPL3)
depends=(glibc)
makedepends=(git gprbuild)
-source=(git+https://github.com/alire-project/alire.git#tag=v0.7.1
+source=("$pkgname-$pkgver.tar.gz::https://github.com/alire-project/alire/archive/refs/tags/v$pkgver.tar.gz"
git+https://github.com/alire-project/xmlezout.git
git+https://github.com/mosteo/ajunitgen.git
git+https://github.com/mosteo/aaa.git
@@ -22,24 +22,25 @@ git+https://github.com/mosteo/ansi-ada
git+https://github.com/mosteo/uri-ada.git
git+https://github.com/mosteo/minirest
git+https://github.com/Fabien-Chouteau/spdx_ada#commit=319ca7bcc1e2eb1843aad1f64aca3ecba91a2bcc)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+b2sums=('bad08a570d464d454739edb42717a5ad33eb132dea4c3f2752e26bf122aa6a6b058e1b89987a9c8a6c5d432492b29586fbefad0e54207f8e7a9601ef1bbba9a0'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare()
{
# Get the submodules from the sources above
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
+ git submodule init
git config submodule.deps/xmlezout.url "$srcdir"/xmlezout
git config submodule.deps/ajunitgen.url "$srcdir"/ajunitgen
git config submodule.deps/aaa.url "$srcdir"/aaa