summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Lagnese2022-02-04 13:01:02 -0800
committerTim Lagnese2022-02-04 13:01:02 -0800
commite33c7647ca448910f6a4c2a0a422cf8d2e71d57f (patch)
treecf1acce4198189d18328f941b239ecee9acdaa23
parentf30b7ba6a5a4d637b4100ce9a55d3843955fd403 (diff)
downloadaur-e33c7647ca448910f6a4c2a0a422cf8d2e71d57f.tar.gz
Add check function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bffd47cee39..a9045c908434 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alire
pkgdesc = A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam.
pkgver = 1.1.2
- pkgrel = 3
+ pkgrel = 4
url = https://alire.ada.dev/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a7be2c97ddf7..124e725c68ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=alire
pkgver=1.1.2
-pkgrel=3
+pkgrel=4
pkgdesc="A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam."
arch=('i686' 'x86_64')
url="https://alire.ada.dev/"
@@ -59,6 +59,11 @@ build() {
gprbuild -j0 -P alr_env -cargs -gnatws
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver/testsuite"
+ GIT_CONFIG_GLOBAL=/dev/null GIT_CONFIG_SYSTEM=/dev/null ./run.py
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
gprinstall -P alr_env -p --prefix="$pkgdir/usr"