summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Lagnese2022-02-04 03:06:00 -0800
committerTim Lagnese2022-02-04 03:06:00 -0800
commitf30b7ba6a5a4d637b4100ce9a55d3843955fd403 (patch)
tree51e51a876158769b29ef6d95e5d747fb13d5f43a
parent8bd3dd8fba89a3f5a8eb3cb893f121b8c017e82f (diff)
downloadaur-f30b7ba6a5a4d637b4100ce9a55d3843955fd403.tar.gz
Add bash completions, and update build manifest
-rw-r--r--.SRCINFO2
-rw-r--r--.build.yml1
-rw-r--r--PKGBUILD4
3 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94c077d7c1ce..1bffd47cee39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alire
pkgdesc = A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam.
pkgver = 1.1.2
- pkgrel = 2
+ pkgrel = 3
url = https://alire.ada.dev/
arch = i686
arch = x86_64
diff --git a/.build.yml b/.build.yml
index 9f47f39282e0..680d0e044302 100644
--- a/.build.yml
+++ b/.build.yml
@@ -5,6 +5,7 @@ packages:
- gprbuild-bootstrap
- xmlada
- git
+ - unzip
tasks:
- prepare: |
git clone https://aur.archlinux.org/gprbuild.git
diff --git a/PKGBUILD b/PKGBUILD
index 5066b1e68e0a..a7be2c97ddf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=alire
pkgver=1.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam."
arch=('i686' 'x86_64')
url="https://alire.ada.dev/"
@@ -62,6 +62,8 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
gprinstall -P alr_env -p --prefix="$pkgdir/usr"
+ # TODO: Install the bash completion under /usr/share
+ install -D scripts/alr-completion.bash "$pkgdir/usr/share/bash-completion/completions/alr"
}
# vim:set ts=2 sw=2 et: