summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAidan Harris2016-11-28 04:13:22 +0000
committerAidan Harris2016-11-28 04:13:22 +0000
commitbdf5cfb7d853ecef81f5fb1bd588abefa7aebaf3 (patch)
tree059f30260ad5b0b638456e160ee843283fa01fcf
parentb2622e6863730195b03f62619e28b2f685b4ba00 (diff)
downloadaur-bdf5cfb7d853ecef81f5fb1bd588abefa7aebaf3.tar.gz
Better 32 bit support (You should - hopefully - no longer need to edit the PKGBUILD to install on 32 bit systems
-rw-r--r--PKGBUILD16
-rw-r--r--alkasir-client.install4
-rw-r--r--alkasir-client.service3
3 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e953ddd5c72c..da886536ebc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,18 @@
pkgname='alkasir-client'
pkgver=0.4.7
pkgrel=1
-arch=('x86_64')
-_arch="amd64" # Change to '386' to install the 32 bit client
+arch=(
+ 'x86_64'
+ 'i386'
+)
+
+if [ "$arch" == "x86_64" ]
+then
+ _arch="amd64"
+else
+ _arch="386"
+fi
+
url="https://alkasir.com/"
depends=('glibc')
makedepends=('links') # Links is needed to download the license agreement
@@ -19,7 +29,7 @@ pkgdesc="Alkasir is a cross-platform, open-source and robust website censorship
source=("https://github.com/alkasir/alkasir/releases/download/$pkgver/alkasir-client_linux-$_arch.tar.gz"
"alkasir-client.service")
md5sums=('8490b46497d51de548341cf81d7989ee'
- '741b2eee3c554d555f932cf0011da922'
+ '8068200941009b41885ffa93659f7f6e'
)
install="alkasir-client.install"
diff --git a/alkasir-client.install b/alkasir-client.install
index 3efe02ec1aec..c6a2b378867b 100644
--- a/alkasir-client.install
+++ b/alkasir-client.install
@@ -7,6 +7,6 @@ post_install() {
}
post_upgrade() {
- chown -R root:root /opt/alkasir-client-linux-amd64 &> /dev/null 2>&1
- chown -R root:root /opt/alkasir-client-linux-386 &> /dev/null 2>&1
+ chown -R root:root /opt/alkasir-client-linux-amd64 &> /dev/null 2>&1 || true
+ chown -R root:root /opt/alkasir-client-linux-386 &> /dev/null 2>&1 || true
}
diff --git a/alkasir-client.service b/alkasir-client.service
index 4beac4eb83eb..1138db688e35 100644
--- a/alkasir-client.service
+++ b/alkasir-client.service
@@ -2,9 +2,6 @@
Description=Alkasir Client Service
[Service]
-# Won't work with 32bit version
-# To Do:
-# * Fix Me
ExecStart=/opt/alkasir-client-linux-amd64/alkasir-client_linux_amd64
Restart=on-failure