summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak2019-03-30 01:32:32 +0100
committerSebastian Krzyszkowiak2019-04-11 01:44:50 +0200
commit6a739515063e29d801544f54f3803142d8085b95 (patch)
tree70b20ccecaa2343b517be0a7cba4ffbf27f55695
downloadaur-6a739515063e29d801544f54f3803142d8085b95.tar.gz
initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD48
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ac262fd43c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = allegro-sdl-git
+ pkgdesc = Portable library mainly aimed at video game and multimedia programming, built with SDL2 backend
+ pkgver = r11496.c9d6a8236
+ pkgrel = 1
+ url = https://liballeg.org/
+ arch = x86_64
+ license = ZLIB
+ makedepends = cmake
+ makedepends = git
+ makedepends = glu
+ makedepends = libtheora
+ makedepends = mesa-libgl
+ makedepends = ninja
+ makedepends = opusfile
+ makedepends = pandoc
+ depends = dumb
+ depends = gtk2
+ depends = jack
+ depends = libgl
+ depends = libpulse
+ depends = libtheora
+ depends = libwebp
+ depends = libxpm
+ depends = libxxf86dga
+ depends = opusfile
+ depends = physfs
+ depends = sdl2
+ provides = allegro
+ conflicts = allegro
+ source = git+https://github.com/liballeg/allegro5.git
+ md5sums = SKIP
+
+pkgname = allegro-sdl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f57e80a2f9ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Sebastian Krzyszkowiak <dos@dosowisko.net>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: arjan <arjan@archlinux.org>
+
+pkgname=allegro-sdl-git
+pkgver=r11496.c9d6a8236
+pkgrel=1
+pkgdesc='Portable library mainly aimed at video game and multimedia programming, built with SDL2 backend'
+arch=(x86_64)
+url='https://liballeg.org/'
+license=('ZLIB')
+provides=("${pkgname%-sdl-git}")
+conflicts=("${pkgname%-sdl-git}")
+makedepends=(cmake git glu libtheora mesa-libgl ninja opusfile pandoc)
+depends=(dumb gtk2 jack libgl libpulse libtheora libwebp libxpm libxxf86dga opusfile physfs sdl2)
+source=("git+https://github.com/liballeg/allegro5.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/allegro5"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "../allegro5" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DALLEGRO_SDL=ON \
+ -DWANT_DOCS_HTML=OFF \
+ -G Ninja
+ ninja
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm644 "allegro5/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Fix man path
+ mv -v -f "$pkgdir/usr/man" "$pkgdir/usr/share/man"
+}
+
+# getver: liballeg.org/a5docs/trunk
+# vim: ts=2 sw=2 et: