summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Tsokurov2016-02-10 18:16:25 +0200
committerAlex Tsokurov2016-02-10 18:16:25 +0200
commitbd3ee9c242da33753b9e63ab017275c22cb51480 (patch)
tree1dfeb4493c81e3e8bf033be56a94deab487abedf
downloadaur-bd3ee9c242da33753b9e63ab017275c22cb51480.tar.gz
first commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD30
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54a43d6d9633
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 16:15:24 UTC 2016
+pkgbase = allegro5-git
+ pkgdesc = Portable library mainly aimed at video game and multimedia programming
+ pkgver = 5.1.11.259.g58360b3
+ pkgrel = 1
+ url = http://liballeg.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = mesa
+ makedepends = glu
+ makedepends = git
+ depends = jack
+ depends = libxpm
+ depends = libxxf86dga
+ depends = libgl
+ depends = physfs
+ depends = gtk2
+ depends = libpulse
+ depends = alsa-lib
+ source = git+https://github.com/liballeg/allegro5.git
+ md5sums = SKIP
+
+pkgname = allegro5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9de082693c7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_pkgname=allegro5
+pkgname=$_pkgname-git
+pkgver=5.1.11.259.g58360b3
+pkgrel=1
+pkgdesc='Portable library mainly aimed at video game and multimedia programming'
+arch=('i686' 'x86_64')
+url='http://liballeg.org/'
+license=('custom')
+depends=('jack' 'libxpm' 'libxxf86dga' 'libgl' 'physfs' 'gtk2' 'libpulse' 'alsa-lib')
+makedepends=('cmake' 'gcc' 'mesa' 'glu' 'git')
+source=('git+https://github.com/liballeg/allegro5.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe | sed s/-/./g
+}
+
+build() {
+ cd $_pkgname
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make -j2
+}
+
+package() {
+ cd $_pkgname/build
+ make DESTDIR=$pkgdir install
+}