summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavel Merzlyakov2018-11-14 23:09:11 +0200
committerPavel Merzlyakov2018-11-14 23:09:11 +0200
commit9714f2ba211a02a529e0a32c6ff164128ba71e6c (patch)
tree47234938938f33f9b8d9f8105e543291fec8f21c
parent187592e20b59121da6d5b2d53b87e66b3d711605 (diff)
downloadaur-9714f2ba211a02a529e0a32c6ff164128ba71e6c.tar.gz
Update to version 2.7.0
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01d271303c09..f795124c1be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Contributor: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
pkgname=allure-commandline
-_pkgname=allure-core
-pkgver=1.5.0
+_pkgname=allure
+pkgver=2.7.0
pkgrel=1
pkgdesc='A flexible lightweight multi-language test report tool with the possibility to add steps, attachments, parameters and so on.'
arch=('i686' 'x86_64')
url='http://allure.qatools.ru'
-depends=('java-runtime')
-source=("https://github.com/allure-framework/allure1/releases/download/${_pkgname}-${pkgver}/${pkgname}.tar.gz" "allure")
-md5sums=('2182aea7a19ee8966665904fb7572eba' 'd5cda88380d1d44d68e3eb72df369cd9')
+depends=('jdk8-openjdk')
+source=("https://github.com/allure-framework/allure2/releases/download/${pkgver}/${_pkgname}-${pkgver}.tgz" "allure")
+md5sums=('14e582816aa4c5148439dc6bc3dbe6b2' 'd5cda88380d1d44d68e3eb72df369cd9')
package() {
cd "${srcdir}"
install -Dm755 allure "${pkgdir}/usr/bin/allure"
installdir="${pkgdir}/opt/${pkgname}"
mkdir -p "${installdir}"
- for dir in app bin conf lib plugins
+ for dir in bin config lib plugins
do
- cp -r "./${dir}" "${installdir}/"
+ cp -r "./${_pkgname}-${pkgver}/${dir}" "${installdir}/"
done
}