summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoey Darwish Dror2019-05-27 14:29:19 +0300
committerRoey Darwish Dror2019-05-27 14:29:19 +0300
commit45edacc5f0931dbf9918016c3729d3db8f27597a (patch)
tree78b328ae7c9a55d273e272ac083ae7ac7ea51175
parent06196359222f8367a82578b51b626b65796fc308 (diff)
downloadaur-45edacc5f0931dbf9918016c3729d3db8f27597a.tar.gz
Fix update script
-rwxr-xr-xupdate.fish6
1 files changed, 3 insertions, 3 deletions
diff --git a/update.fish b/update.fish
index e7b543c9f030..9786d74012c5 100755
--- a/update.fish
+++ b/update.fish
@@ -1,9 +1,9 @@
#!/usr/bin/env fish
-set version $argv[1]
-set hash (string sub -l 64 (curl -L https://github.com/r-darwish/alma/archive/v$version.tar.gz ^/dev/null | sha256sum))
+set -l package_version $argv[1]
+set -l hash (string sub -l 64 (curl -L https://github.com/r-darwish/alma/archive/v$package_version.tar.gz | sha256sum))
sed -E "s/sha256sums=.*\$/sha256sums=\('$hash'\)/g" -i PKGBUILD
-sed -E "s/pkgver=.*\$/pkgver=$version/g" -i PKGBUILD
+sed -E "s/pkgver=.*\$/pkgver=$package_version/g" -i PKGBUILD
makepkg --printsrcinfo > .SRCINFO
makepkg