summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-08-11 17:03:09 +0100
committerMilk Brewster2020-08-11 17:03:09 +0100
commit74e91478f814d2f0e476c9f5b3a9d6ca09da0e5d (patch)
tree44ad01f234ebe9b85fe7548ede9adbc66d5fe419
downloadaur-74e91478f814d2f0e476c9f5b3a9d6ca09da0e5d.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f437056c37ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = alo.lv2-git
+ pkgdesc = A Looper plugin originally made for the MOD Duo
+ pkgver = 0.7.r14.ge8cd661
+ pkgrel = 1
+ url = https://github.com/devcurmudgeon/alo
+ arch = x86_64
+ groups = lv2-plugins
+ groups = pro-audio
+ license = GPL3
+ checkdepends = lv2lint
+ makedepends = git
+ makedepends = lv2
+ depends = cairo
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
+ provides = alo.lv2
+ conflicts = alo.lv2
+ source = alo.lv2::git+https://github.com/devcurmudgeon/Alo
+ md5sums = SKIP
+
+pkgname = alo.lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54cf142931af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Milkii Brewster <milkii on freenode IRC>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name="Alo"
+_pkgname="${_name,,}.lv2"
+_plugin_uri="https://github.com/devcurmudgeon/${_name}"
+pkgname="${_pkgname}-git"
+pkgdesc="A Looper plugin originally made for the MOD Duo "
+pkgver=0.7.r14.ge8cd661
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/devcurmudgeon/alo"
+license=('GPL3')
+groups=('lv2-plugins' 'pro-audio')
+depends=('cairo' 'gcc-libs' 'glibc' 'libx11')
+makedepends=('git' 'lv2')
+checkdepends=('lv2lint')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/devcurmudgeon/${_name}")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"/source
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}"/source
+ # echo lv2lint -Mpack -I "${_name}.lv2/" "${_plugin_uri}"
+ # lv2lint -Mpack -I "${_name}.lv2/" "${_plugin_uri}"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p $pkgdir/usr/lib/lv2
+ cp -r source/alo.lv2 $pkgdir/usr/lib/lv2
+}