summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Denhardt2015-11-24 19:36:36 -0500
committerIan Denhardt2015-11-24 19:36:36 -0500
commit1ea714f791a7c52120432ee33b647ee0bf33bcd8 (patch)
treeec82fe81d1b27e2d4a52c562cb796963d8a6e6f1
parent29a74e03baeb1f7562e5b895cc78f408d391be47 (diff)
downloadaur-1ea714f791a7c52120432ee33b647ee0bf33bcd8.tar.gz
Install extras & introduce build function
* Install things from extra: docs, man pages, zsh auto-completion, example themes * Introduce build function * Add python2-sphinx to makedepends Thanks to AUR user lucc for the suggestions.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4a02d54c250..299f4edb5ca1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = alot
pkgdesc = terminal-based MUA for the notmuch mail system
pkgver = 0.3.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pazz/alot
arch = any
license = GPL
+ makedepends = python2-sphinx
depends = notmuch
depends = python2-pygpgme
depends = python2-magic
diff --git a/PKGBUILD b/PKGBUILD
index dc33c3f47e93..167168ba86e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,32 @@
pkgname=alot
pkgver=0.3.6
-pkgrel=1
+pkgrel=2
pkgdesc="terminal-based MUA for the notmuch mail system"
arch=(any)
url="https://github.com/pazz/alot"
license=(GPL)
depends=(notmuch python2-pygpgme python2-magic python2-configobj python2-urwid python2-twisted)
+makedepends=(python2-sphinx)
options=(!emptydirs)
source=($pkgname-$pkgver.tar.gz::https://github.com/pazz/$pkgname/archive/$pkgver.tar.gz)
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+ make SPHINXBUILD=sphinx-build2 -C docs man html
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
python2 setup.py install --optimize=1 --root="$pkgdir"
+ install -Dm644 extra/completion/alot-completion.zsh \
+ "$pkgdir/usr/share/zsh/functions/_alot"
+ install -dm755 "$pkgdir/usr/share/alot/themes/examples"
+ install -Dm644 extra/themes/{mutt,solarized,solarized_dark,sup,tomorrow} \
+ "${pkgdir}/usr/share/alot/themes/examples"
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ cp -a docs/build/html/* "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 docs/build/man/alot.1 "$pkgdir/usr/share/man/man1/alot.1"
}
md5sums=('527ee0b24bf444e61b05604efe4658b0')