summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Denhardt2015-06-09 11:11:24 -0400
committerIan Denhardt2015-06-09 11:11:24 -0400
commit75baaeb20735d5451723528c531a2be5bde06387 (patch)
treed4a154b362aa30d94373332005771e639b9d9d94
downloadaur-75baaeb20735d5451723528c531a2be5bde06387.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4a02d54c250
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = alot
+ pkgdesc = terminal-based MUA for the notmuch mail system
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/pazz/alot
+ arch = any
+ license = GPL
+ depends = notmuch
+ depends = python2-pygpgme
+ depends = python2-magic
+ depends = python2-configobj
+ depends = python2-urwid
+ depends = python2-twisted
+ options = !emptydirs
+ source = alot-0.3.6.tar.gz::https://github.com/pazz/alot/archive/0.3.6.tar.gz
+ md5sums = 527ee0b24bf444e61b05604efe4658b0
+
+pkgname = alot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc33c3f47e93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Mark Foxwell <fastfret79@archlinux.org.uk>
+# Contributor: Nicolas Pouillard [https://nicolaspouillard.fr]
+# Contributor: seschwar -- contact via Arch Linux forum or AUR
+# Maintainer: Ian Denhardt <ian@zenhack.net>
+
+pkgname=alot
+pkgver=0.3.6
+pkgrel=1
+pkgdesc="terminal-based MUA for the notmuch mail system"
+arch=(any)
+url="https://github.com/pazz/alot"
+license=(GPL)
+depends=(notmuch python2-pygpgme python2-magic python2-configobj python2-urwid python2-twisted)
+options=(!emptydirs)
+source=($pkgname-$pkgver.tar.gz::https://github.com/pazz/$pkgname/archive/$pkgver.tar.gz)
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --optimize=1 --root="$pkgdir"
+}
+md5sums=('527ee0b24bf444e61b05604efe4658b0')