summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Denhardt2016-10-30 10:15:11 -0400
committerIan Denhardt2016-10-30 10:17:44 -0400
commitdc92a700ed2334c304b1702ad138734b1e68ef9e (patch)
tree1e218ff2dbae71ff76af75e413217bcf44518342
parent38f77113f83b9ee573e8284fcd83b2686859b32b (diff)
downloadaur-dc92a700ed2334c304b1702ad138734b1e68ef9e.tar.gz
Update the name of the magic dependency.
Thanks to Lokaltog on AUR for pointing this out: > It seems the python2-magic package has changed name from Magic-file- > extensions to file-magic, which breaks this package. This change > resolves the issue for me:
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 823175d1728e..752c8c77f5f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=alot
pkgver=0.3.7
-pkgrel=1
+pkgrel=2
pkgdesc="terminal-based MUA for the notmuch mail system"
arch=(any)
url="https://github.com/pazz/alot"
@@ -24,11 +24,11 @@ source=($pkgname-$pkgver.tar.gz::https://github.com/pazz/$pkgname/archive/$pkgve
build() {
cd "$srcdir/$pkgname-$pkgver"
- # The archlinux package python2-magic's egg calls itself
- # "Magic-file-extensions", as opposed to the python-magic on pypi. The
- # result is that the alot executable can't find the module, so we patch
- # setup.py to fix the dependency:
- sed -i -e 's/python-magic/Magic-file-extensions/' setup.py
+ # The archlinux package python2-magic's egg calls itself "file-magic",
+ # as opposed to the python-magic on pypi. The result is that the alot
+ # executable can't find the module, so we patch setup.py to fix the
+ # dependency:
+ sed -i -e 's/python-magic/file-magic/' setup.py
python2 setup.py build
make SPHINXBUILD=sphinx-build2 -C docs man html
}