summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Reinert2016-05-23 11:41:05 +0200
committerJoakim Reinert2016-05-23 11:41:05 +0200
commit6511c64ca8adba4d0549663bda08e7225bf55ea4 (patch)
tree5a0520553c50b57be30d5ed4b8c135d05391c033
downloadaur-6511c64ca8adba4d0549663bda08e7225bf55ea4.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD52
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..149954d62408
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Mon May 23 09:40:26 UTC 2016
+pkgbase = alot-git
+ pkgdesc = terminal-based MUA for the notmuch mail system
+ pkgver = 0.3.7
+ pkgrel = 1
+ url = https://github.com/pazz/alot
+ arch = any
+ license = GPL
+ makedepends = python2-sphinx
+ makedepends = git
+ depends = notmuch
+ depends = python2-pygpgme
+ depends = python2-magic
+ depends = python2-configobj
+ depends = python2-urwid
+ depends = python2-urwidtrees
+ depends = python2-twisted
+ provides = alot
+ conflicts = alot
+ options = !emptydirs
+ source = git+https://github.com/pazz/alot.git
+ md5sums = SKIP
+
+pkgname = alot-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2afa76e7746c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/alot/
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45b20e9b85fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Mark Foxwell <fastfret79@archlinux.org.uk>
+# Contributor: Nicolas Pouillard [https://nicolaspouillard.fr]
+# Contributor: seschwar -- contact via Arch Linux forum or AUR
+# Contributor: Ian Denhardt <ian@zenhack.net>
+# Maintainer: Joakim Reinert <mail+aur@jreinert.com>
+
+_gitname=alot
+pkgname=alot-git
+pkgver=0.3.7
+pkgrel=1
+pkgdesc="terminal-based MUA for the notmuch mail system"
+arch=(any)
+url="https://github.com/pazz/alot"
+license=(GPL)
+depends=(notmuch
+ python2-pygpgme
+ python2-magic
+ python2-configobj
+ python2-urwid
+ python2-urwidtrees
+ python2-twisted)
+makedepends=(python2-sphinx git)
+provides=(alot)
+conflicts=(alot)
+options=(!emptydirs)
+source=('git+https://github.com/pazz/alot.git')
+md5sums=(SKIP)
+
+build() {
+ cd "$srcdir/$_gitname"
+
+ # The archlinux package python2-magic's egg calls itself
+ # "Magic-file-extensions", as opposed to the python-magic on pypi. The
+ # result is that the alot executable can't find the module, so we patch
+ # setup.py to fix the dependency:
+ sed -i -e 's/python-magic/Magic-file-extensions/' setup.py
+ python2 setup.py build
+ make SPHINXBUILD=sphinx-build2 -C docs man html
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --optimize=1 --root="$pkgdir"
+ install -Dm644 extra/completion/alot-completion.zsh \
+ "$pkgdir/usr/share/zsh/functions/_alot"
+ install -dm755 "$pkgdir/usr/share/alot/themes/examples"
+ install -Dm644 extra/themes/{mutt,solarized,solarized_dark,sup,tomorrow} \
+ "${pkgdir}/usr/share/alot/themes/examples"
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ cp -a docs/build/html/* "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 docs/build/man/alot.1 "$pkgdir/usr/share/man/man1/alot.1"
+}