summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Melzer2018-07-23 00:34:42 +0200
committerNorbert Melzer2018-07-23 00:39:33 +0200
commit25b1d21b26d86ad5199a1239805bacf24b9ae041 (patch)
tree5e8da64003244b09871dcea45a8080ad2b833af4
downloadaur-25b1d21b26d86ad5199a1239805bacf24b9ae041.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD59
-rw-r--r--rebar.config.patch8
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9859afe0905e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = alpaca
+ pkgver = 0.2.8
+ pkgrel = 1
+ arch = any
+ license = Apache2
+ makedepends = rebar3
+ depends = erlang-nox
+ provides = alpaca
+ options = !strip
+ options = !docs
+ options = !libtool
+ options = !staticlibs
+ source = https://github.com/alpaca-lang/alpaca/archive/v0.2.8.tar.gz
+ source = rebar.config.patch
+ md5sums = a456366aa77498b80ab6b8dc2adcca1f
+ md5sums = 312ad70a3e6b0cf03e7d4d71daa5456f
+
+pkgname = alpaca
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..32fe81df2757
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+v*.tar.gz
+alpaca-*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd5ad0c20afd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Norbert Melzer <timmelzer PLUS aur AT gmail DOT com>
+
+pkgname=alpaca
+pkgver="0.2.8"
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url=""
+license=('Apache2')
+depends=('erlang-nox')
+makedepends=('rebar3')
+checkdepends=()
+optdepends=()
+provides=('alpaca')
+conflicts=()
+replaces=()
+backup=()
+options=(!strip !docs !libtool !staticlibs)
+install=
+changelog=
+source=("https://github.com/alpaca-lang/${pkgname}/archive/v${pkgver}.tar.gz"
+ "rebar.config.patch")
+md5sums=('a456366aa77498b80ab6b8dc2adcca1f'
+ '312ad70a3e6b0cf03e7d4d71daa5456f')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -Np0 -i "${srcdir}/rebar.config.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ rebar3 as default compile
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+
+ ## Currently there are tests failing!
+ # rebar3 eunit
+ # rebar3 dialyzer
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ local basedir="${pkgdir}/usr/local/lib/alpaca"
+
+ mkdir -p "${basedir}/beams"
+ mkdir -p "${basedir}/src"
+
+ install -D README.md "${basedir}/README.md"
+ install -D Tour.md "${basedir}/Tour.md"
+ install -D code_of_conduct.md "${basedir}/code_of_conduct.md"
+ install -D _build/default/lib/alpaca/ebin/*.beam "${basedir}/beams"
+ install -D src/* "${basedir}/src"
+}
diff --git a/rebar.config.patch b/rebar.config.patch
new file mode 100644
index 000000000000..58e13afbe98e
--- /dev/null
+++ b/rebar.config.patch
@@ -0,0 +1,8 @@
+--- rebar.config 2018-01-02 07:11:35.000000000 +0100
++++ rebar.config 2018-07-22 17:55:39.244807393 +0200
+@@ -1,4 +1,4 @@
+-{erl_opts, [debug_info, warnings_as_errors, {gettext, alpaca_compiled_po}]}.
++{erl_opts, [debug_info, {gettext, alpaca_compiled_po}]}.
+ {xrl_opts, [{report, true}, {verbose, true}]}.
+ {deps, [ {epo_runtime, {git, "git://github.com/brigadier/epo_runtime.git",
+ {tag, "0.3"}}},