summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Carpio2024-09-17 19:44:25 +0200
committerFrancisco Carpio2024-09-17 19:44:25 +0200
commit1c186862a552b53a3b1cd7f6bfcc6679cc50d4dd (patch)
treef5f7b8d3d4a1644591f0dcd53c80a9ec6e6840f7
downloadaur-1c186862a552b53a3b1cd7f6bfcc6679cc50d4dd.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..943aa8f552f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = alpaca-git
+ pkgdesc = An Ollama client made with GTK4 and Adwaita
+ pkgver = 2.0.2.r11.g25eb152
+ pkgrel = 1
+ url = https://github.com/jeffser/Alpaca
+ arch = any
+ license = GPL-3.0
+ makedepends = meson
+ depends = ollama
+ depends = python-requests
+ depends = python-pillow
+ depends = python-pypdf
+ depends = python-pytube
+ depends = python-html2text
+ conflicts = alpaca-ai
+ source = git+https://github.com/jeffser/Alpaca.git
+ md5sums = SKIP
+
+pkgname = alpaca-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16c02515dc50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Francisco Carpio <carpiofj at gmail dot com>
+pkgname=alpaca-git
+_pkgname=Alpaca
+pkgver=2.0.2.r11.g25eb152
+pkgrel=1
+pkgdesc="An Ollama client made with GTK4 and Adwaita"
+arch=('any')
+url="https://github.com/jeffser/Alpaca"
+license=('GPL-3.0')
+makedepends=('meson')
+depends=(
+ 'ollama'
+ 'python-requests'
+ 'python-pillow'
+ 'python-pypdf'
+ 'python-pytube'
+ 'python-html2text'
+)
+conflicts=('alpaca-ai')
+source=("git+https://github.com/jeffser/$_pkgname.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ meson setup _build
+ meson compile -C _build
+}
+
+package() {
+ cd "$srcdir/$_pkgname/_build"
+ sudo meson install --destdir="$pkgdir"
+}
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}