summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-14 13:47:11 +0800
committerzxp198210052023-11-14 13:47:11 +0800
commite1deb3f7ef0f95bf7c4ad8e01bce2e1eab299602 (patch)
treeec2599feb8e5e0dd5f34b72694ff63a97372b873
parentd4f083e3796088bd5cef538f8a7424deed41920e (diff)
downloadaur-e1deb3f7ef0f95bf7c4ad8e01bce2e1eab299602.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
2 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 045d9e64ebe2..ebebd7e7af06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alphabiz-bin
pkgdesc = Web3 ecosystem - enable developers to build fully decentralized media platform and blockchain-based marketplace
pkgver = 0.3.1
- pkgrel = 2
+ pkgrel = 4
url = https://alpha.biz/
arch = x86_64
license = GPL2
@@ -12,20 +12,15 @@ pkgbase = alphabiz-bin
depends = java-runtime
depends = libxfixes
depends = mesa
- depends = glibc
depends = libx11
depends = libxkbcommon
depends = libxcb
depends = gtk3
- depends = bash
- depends = dbus
- depends = gcc-libs
depends = libxrandr
depends = nss
depends = libdrm
depends = libxext
depends = at-spi2-core
- depends = glib2
depends = libcups
depends = libxdamage
depends = nspr
diff --git a/PKGBUILD b/PKGBUILD
index 1d40247c6ec4..9363b664d211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,40 @@
pkgname=alphabiz-bin
_pkgname=Alphabiz
pkgver=0.3.1
-pkgrel=2
+pkgrel=4
pkgdesc="Web3 ecosystem - enable developers to build fully decentralized media platform and blockchain-based marketplace"
arch=('x86_64')
url="https://alpha.biz/"
-_githuburl="https://github.com/tanshuai/alphabiz"
+_ghurl="https://github.com/tanshuai/alphabiz"
license=('GPL2')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('expat' 'cairo' 'wayland' 'pango' 'java-runtime' 'libxfixes' 'mesa' 'glibc' 'libx11' 'libxkbcommon' 'libxcb' 'gtk3' 'bash' \
- 'dbus' 'gcc-libs' 'libxrandr' 'nss' 'libdrm' 'libxext' 'at-spi2-core' 'glib2' 'libcups' 'libxdamage' 'nspr' 'alsa-lib' 'libxcomposite')
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}.deb")
+depends=(
+ 'expat'
+ 'cairo'
+ 'wayland'
+ 'pango'
+ 'java-runtime'
+ 'libxfixes'
+ 'mesa'
+ 'libx11'
+ 'libxkbcommon'
+ 'libxcb'
+ 'gtk3'
+ 'libxrandr'
+ 'nss'
+ 'libdrm'
+ 'libxext'
+ 'at-spi2-core'
+ 'libcups'
+ 'libxdamage'
+ 'nspr'
+ 'alsa-lib'
+ 'libxcomposite'
+)
+source=("${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}.deb")
sha256sums=('e3731b4d2ec237d39c7811aead372d431632b8dbe2ac5382884521fcf84f82f9')
-prepare() {
+build() {
bsdtar -xf "${srcdir}/data.tar.zst"
sed "s|--|--no-sandbox|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}