summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornarunlifescience2016-05-06 00:52:07 -0500
committernarunlifescience2016-05-06 00:52:07 -0500
commit35e2c1fd67848e0d0278fc0a079b0f39f34016be (patch)
tree020d43367cc6c3c570a3889c87744a29473894da
downloadaur-35e2c1fd67848e0d0278fc0a079b0f39f34016be.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--alphaplot.install11
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c66047bf620f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = alphaplot
+ pkgdesc = Application for Scientific Data Analysis and Visualization, fork of SciDavis
+ pkgver = 0.01
+ pkgrel = 1
+ install = alphaplot.install
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ makedepends = boost
+ makedepends = cmake
+ depends = gsl
+ depends = glu
+ depends = mesa
+ depends = muparser
+ depends = python2-pyqt4
+ depends = shared-mime-info
+ depends = qwt5
+ depends = qwtplot3d
+ source = git+https://github.com/narunlifescience/alphaplot.git
+ sha256sums = SKIP
+
+pkgname = alphaplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4ab8c66776a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Arun Narayanankutty <n.arun.lifescience@gmail.com>
+
+pkgname=alphaplot
+pkgver=0.01
+pkgrel=1
+pkgdesc="Application for Scientific Data Analysis and Visualization, fork of SciDavis"
+arch=('i686' 'x86_64')
+license=('GPL-2')
+
+# make dependancies
+makedepends=('boost' 'cmake')
+depends=('gsl' 'glu' 'mesa' 'muparser' 'python2-pyqt4' 'shared-mime-info'
+ 'qwt5' 'qwtplot3d')
+
+# source download from git repo & prepare
+source=(git+https://github.com/narunlifescience/alphaplot.git)
+install=${pkgname}.install
+sha256sums=('SKIP')
+prepare() {
+ cd "${srcdir}"
+}
+
+# start building
+build() {
+ cd "${srcdir}/${pkgname}"
+ qmake-qt4
+ make
+}
+
+# prepare package
+package() {
+ cd "${srcdir}/${pkgname}"
+ make INSTALL_ROOT="${pkgdir}" DESTDIR="${pkgdir}" install
+
+ # remove liborigin files since it uses static library
+ rm -rf "${pkgdir}/usr/local"
+}
diff --git a/alphaplot.install b/alphaplot.install
new file mode 100644
index 000000000000..18032f614862
--- /dev/null
+++ b/alphaplot.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+ update-desktop-database -q
+ update-mime-database /usr/share/mime/ > /dev/null
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: