summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-01-07 04:47:03 -0800
committerxiota2024-01-07 04:47:03 -0800
commit6c60df2b26cf6e63bd02897702e6babb734755f1 (patch)
tree4ae866ee19af14ab4b1b30b9fe6bb0cfeb3c7302
parent2cf3167c4e9c664f97d62e1e3d6b19700268bcd4 (diff)
downloadaur-6c60df2b26cf6e63bd02897702e6babb734755f1.tar.gz
update conflicts, license
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 656d97c9d6a7..be6d93566f52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = alphaplot
url = https://github.com/narunlifescience/AlphaPlot
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = boost
makedepends = cmake
makedepends = glu
@@ -16,7 +16,6 @@ pkgbase = alphaplot
depends = qt5-script
depends = qt5-svg
conflicts = alphaplot-bin
- conflicts = alphaplot-git
source = alphaplot-1.02.tar.gz::https://github.com/narunlifescience/AlphaPlot/archive/refs/tags/1.02.tar.gz
sha256sums = 90952b2036b9d25b31c0c8fb34c47ff700bb2847234dda42d900070fc60d3c61
diff --git a/PKGBUILD b/PKGBUILD
index 5d5c926c49d1..71466a47d297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer:
# Contributor: Arun Narayanankutty <n.arun.lifescience@gmail.com>
-#: ${_pkgtype:=git}
+## useful links
+# http://alphaplot.sourceforge.net/
+# https://github.com/narunlifescience/AlphaPlot
-# basic info
+## options
+: ${_build_git:=false}
+
+[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git"
+
+## basic info
_pkgname="alphaplot"
-pkgname="$_pkgname${_pkgtype:+-$_pkgtype}"
+pkgname="$_pkgname${_pkgtype:-}"
pkgver=1.02
pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of SciDavis / QtiPlot"
-#url="http://alphaplot.sourceforge.net/"
url="https://github.com/narunlifescience/AlphaPlot"
arch=('i686' 'x86_64')
-license=('GPL2')
+license=('GPL-2.0-or-later')
# main package
_main_package() {
@@ -30,12 +36,9 @@ _main_package() {
'qt5-tools'
)
- conflicts=(
- alphaplot-bin
- alphaplot-git
- )
+ conflicts=(alphaplot-bin)
- if [ x"$pkgname" == x"$_pkgname" ] ; then
+ if [[ "${_build_git::1}" != "t" ]] ; then
_main_stable
else
_main_git