summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-11-27 17:17:53 -0800
committerxiota2023-11-27 17:17:53 -0800
commita62039e6c3222eaf07f2659d362746b50a7e50e9 (patch)
treea8e2dd5b84ff156f0d61e3f20814ca9fbe417a9b
parent0188d73288bbc39526ee45687b02509e0d9c5fb1 (diff)
downloadaur-a62039e6c3222eaf07f2659d362746b50a7e50e9.tar.gz
Update packaging
* fix pkgver() * remove unnecessary install file * remove unused DESTDIR
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
-rw-r--r--alphaplot-git.install9
4 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 887cfa7dadbf..0585fe406f5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = alphaplot-git
pkgdesc = Application for Scientific Data Analysis and Visualization, fork of SciDavis / QtiPlot git version
- pkgver = r1077.5e8bc859
+ pkgver = 1.02.r19.gda97d1fa
pkgrel = 1
url = http://alphaplot.sourceforge.net/
- install = alphaplot-git.install
arch = i686
arch = x86_64
license = GPL2
@@ -18,7 +17,7 @@ pkgbase = alphaplot-git
depends = qt5-svg
provides = alphaplot
conflicts = alphaplot
- source = alphaplot-git::git+https://github.com/narunlifescience/AlphaPlot.git/#branch=master
- sha512sums = SKIP
+ source = alphaplot-git::git+https://github.com/narunlifescience/AlphaPlot.git
+ sha256sums = SKIP
pkgname = alphaplot-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index b74e738c94fe..fb7b96735717 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bruno Silva <brunofernandes at ua dot pt>
pkgname=alphaplot-git
-pkgver=r1244.da97d1f
+pkgver=1.02.r19.gda97d1fa
pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of SciDavis / QtiPlot git version"
url='http://alphaplot.sourceforge.net/'
@@ -13,29 +13,26 @@ makedepends=('boost' 'cmake' 'qt5-tools' 'glu')
depends=('gsl' 'hicolor-icon-theme' 'qt5-datavis3d' 'qt5-script' 'qt5-svg')
# source download from git repo & prepare
-source=("$pkgname::git+https://github.com/narunlifescience/AlphaPlot.git/#branch=master")
-install=${pkgname}.install
-sha512sums=('SKIP')
+source=("$pkgname::git+https://github.com/narunlifescience/AlphaPlot.git")
+sha256sums=('SKIP')
provides=('alphaplot')
conflicts=('alphaplot')
pkgver() {
cd "$pkgname"
- ( set -o pipefail
- git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
- )
+ git describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' \
+ | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
# start building
build() {
- cd "${srcdir}/${pkgname}"
+ cd "$pkgname"
qmake
make
}
# prepare package
package() {
- cd "${srcdir}/${pkgname}"
- make INSTALL_ROOT="${pkgdir}" DESTDIR="${pkgdir}" install
+ cd "$pkgname"
+ make INSTALL_ROOT="${pkgdir}" install
}
diff --git a/alphaplot-git.install b/alphaplot-git.install
deleted file mode 100644
index 40347bf55e63..000000000000
--- a/alphaplot-git.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
- update-desktop-database -q
- update-mime-database /usr/share/mime/ > /dev/null
-}
-
-post_remove() {
- post_install $1
-}