summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2016-10-21 11:32:55 -0400
committerJameson Pugh2016-10-21 11:32:55 -0400
commit290bf6bf9ed73b3eea55883dc1753bd7ee66ee9e (patch)
tree995821850d7285bdcffc8e94b13a1cee724d9e62
downloadaur-290bf6bf9ed73b3eea55883dc1753bd7ee66ee9e.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..597fb3f98918
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Oct 21 15:32:39 UTC 2016
+pkgbase = alpm_octopi_utils
+ pkgdesc = Alpm utils for Octopi
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://octopiproject.wordpress.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ source = https://github.com/aarnt/alpm_octopi_utils/archive/6d93c06d0feec0df7e5958c33df281eda91a6700.zip
+ sha256sums = 637ce5f534b54576c0e68d22892ba920c61a95d32cb5166633e0a93d325e84d4
+
+pkgname = alpm_octopi_utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c932b45c124
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=alpm_octopi_utils
+pkgver=1.0.0
+pkgrel=1
+_commit=6d93c06d0feec0df7e5958c33df281eda91a6700
+pkgdesc="Alpm utils for Octopi"
+url="https://octopiproject.wordpress.com/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=('vala')
+source=("https://github.com/aarnt/${pkgname}/archive/${_commit}.zip")
+sha256sums=('637ce5f534b54576c0e68d22892ba920c61a95d32cb5166633e0a93d325e84d4')
+
+build() {
+ cd ${pkgname}-${_commit}
+
+ make
+}
+
+package() {
+ cd ${pkgname}-${_commit}
+
+ install -D -m755 src/libalpm_octopi_utils.so ${pkgdir}/usr/lib/libalpm_octopi_utils.so
+ install -D -m644 src/libalpm_octopi_utils.pc ${pkgdir}/usr/lib/pkgconfig/libalpm_octopi_utils.pc
+ install -D -m644 src/alpm_octopi_utils.h ${pkgdir}/usr/include/alpm_octopi_utils.h
+}
+
+# vim:set ts=2 sw=2 et: