summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2020-11-15 20:46:53 +0100
committerMatMoul2020-11-15 20:46:53 +0100
commit427cfef8b4f677b892407fda7c8a0e853f40c467 (patch)
treecc21765c3f7f188dd20a6e7f8627313d0b6c517a
downloadaur-427cfef8b4f677b892407fda7c8a0e853f40c467.tar.gz
New version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e2393d5ade4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = alpm_octopi_utils-dev
+ pkgdesc = Alpm utils for Octopi
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://tintaescura.com/projects/octopi/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ depends = pacman-contrib
+ source = https://github.com/aarnt/alpm_octopi_utils/archive/2bb9349507f8155155c9b5f12b1f30e60e157d30.tar.gz
+ sha256sums = SKIP
+
+pkgname = alpm_octopi_utils-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..468a0a3b527e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: MatMoul <matmoul@gmail.com>
+
+pkgname=alpm_octopi_utils-dev
+pkgver=1.0.2
+_pkgrealbase=alpm_octopi_utils
+_commit=2bb9349507f8155155c9b5f12b1f30e60e157d30
+pkgrel=1
+pkgdesc="Alpm utils for Octopi"
+url="https://tintaescura.com/projects/octopi/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('pacman-contrib')
+makedepends=('vala')
+source=("https://github.com/aarnt/${_pkgrealbase}/archive/${_commit}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${_pkgrealbase}-${_commit}"
+ make
+}
+
+package() {
+ cd "${_pkgrealbase}-${_commit}"
+ install -D -m755 src/libalpm_octopi_utils.so "$pkgdir"/usr/lib/libalpm_octopi_utils.so
+ install -D -m644 src/libalpm_octopi_utils.pc "$pkgdir"/usr/lib/pkgconfig/libalpm_octopi_utils.pc
+ install -D -m644 src/alpm_octopi_utils.h "$pkgdir"/usr/include/alpm_octopi_utils.h
+}
+