summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2020-05-16 12:26:45 +0200
committerStefan Tatschner2020-05-16 12:26:45 +0200
commitf2738f3bcce7d26b419b21b9d972371f6757d188 (patch)
tree068ffaa48e2e9bdfcd03d44a75291d8e7a725410
downloadaur-f2738f3bcce7d26b419b21b9d972371f6757d188.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51022db1ef1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = alps-mail-git
+ pkgdesc = A simple Webmail in Go
+ pkgver = r247.5fee600
+ pkgrel = 1
+ url = https://git.sr.ht/~emersion/koushin
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = alps-mail-git::git+https://git.sr.ht/~emersion/alps
+ sha256sums = SKIP
+
+pkgname = alps-mail-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41952eb30d80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
+
+pkgname=alps-mail-git
+_pkgname=alps
+pkgver=r247.5fee600
+pkgrel=1
+license=('MIT')
+pkgdesc="A simple Webmail in Go"
+makedepends=('go')
+arch=('x86_64')
+url="https://git.sr.ht/~emersion/koushin"
+source=("$pkgname::git+https://git.sr.ht/~emersion/alps")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
+ go build -o $_pkgname ./cmd/alps
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 $_pkgname "${pkgdir}"/usr/bin/$_pkgname
+}