summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJia Li2016-05-02 15:33:27 -0400
committerJia Li2016-05-02 15:33:27 -0400
commit392ead97113b1023df200d263c5eb8582f767001 (patch)
treef6324ca43c79965f49769be141281195c77e271f
downloadaur-392ead97113b1023df200d263c5eb8582f767001.tar.gz
creating package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cefba29fb404
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = alpscore
+ pkgdesc = ALPS Core libraries for numerical simulations of condensed matter systems based on ALPS.
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = http://alpscore.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cmake>=2.8.12
+ depends = boost>=1.54.0
+ depends = hdf5>=1.8
+ optdepends = openmpi: for MPI support
+ optdepends = doxygen: for building low-level docs
+ provides = alpscore=0.5.4
+ conflicts = alpscore-git
+ conflicts = alps
+ source = https://github.com/ALPSCore/ALPSCore/archive/v0.5.4.tar.gz
+ md5sums = b887c9328e2a22afa123663cf888b768
+
+pkgname = alpscore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..879304fde04e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Jia Li <lijia1608@gmail.com>
+pkgname=alpscore
+pkgver=0.5.4
+pkgrel=1
+epoch=
+pkgdesc="ALPS Core libraries for numerical simulations of condensed matter systems based on ALPS."
+arch=(i686 x86_64)
+url="http://alpscore.org"
+license=('GPL')
+depends=('cmake>=2.8.12' 'boost>=1.54.0' 'hdf5>=1.8')
+makedepends=()
+checkdepends=()
+optdepends=('openmpi: for MPI support'
+ 'doxygen: for building low-level docs')
+provides=($pkgname=$pkgver)
+conflicts=(alpscore-git alps)
+install=
+source=("https://github.com/ALPSCore/ALPSCore/archive/v$pkgver.tar.gz")
+md5sums=('b887c9328e2a22afa123663cf888b768')
+
+build() {
+ cd "ALPSCore-$pkgver"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+check() {
+ cd "ALPSCore-$pkgver/build"
+ make test
+}
+
+package() {
+ cd "ALPSCore-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}