summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxqia2016-01-17 12:33:51 -0800
committerMaxqia2016-01-17 12:33:51 -0800
commit01806e24b1d6f012bd1aee49ed6499e1cd741cce (patch)
treecd4d8db13b98bf88f49b354b0c5ea1ff5ce73693
downloadaur-01806e24b1d6f012bd1aee49ed6499e1cd741cce.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
-rw-r--r--als-controller.service12
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d797869f38b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 20:22:01 UTC 2016
+pkgbase = als-controller
+ pkgdesc = ASUS Zenbook ambient light sensor userspace controller.
+ pkgver = 20160117
+ pkgrel = 1
+ url = https://github.com/danieleds/Asus-Zenbook-Ambient-Light-Sensor-Controller
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = als-dkms
+ depends = qt5-base
+ depends = libbsd
+ provides = als-controller
+ conflicts = als-controller
+ source = als-controller::git+https://github.com/danieleds/Asus-Zenbook-Ambient-Light-Sensor-Controller.git
+ source = als-controller.service
+ md5sums = SKIP
+ md5sums = e3a8f7a837f761347487e733e458006a
+
+pkgname = als-controller
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5e9573541843
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+src
+pkg
+als-controller
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae0c75e827bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Maxqia <contrib@maxqia.com>
+
+pkgname=als-controller
+pkgver=20160117
+pkgrel=1
+pkgdesc="ASUS Zenbook ambient light sensor userspace controller."
+arch=('i686' 'x86_64')
+url="https://github.com/danieleds/Asus-Zenbook-Ambient-Light-Sensor-Controller"
+license=('Apache')
+depends=('qt5-base' 'libbsd')
+makedepends=('git' 'als-dkms')
+provides=('als-controller')
+conflicts=('als-controller')
+source=("${pkgname}::git+https://github.com/danieleds/Asus-Zenbook-Ambient-Light-Sensor-Controller.git"
+ "als-controller.service")
+md5sums=('SKIP'
+ 'e3a8f7a837f761347487e733e458006a')
+
+prepare() {
+ cd ${pkgname}/example
+ sed -i 's|/bin/bash|/usr/bin/env bash|;s|"\$DIR"/\.\./service/||' switch.sh
+}
+
+build() {
+ cd ${pkgname}/service
+ [[ "$CARCH" = "x86_64" ]] \
+ && qmake als-controller.pro -r -spec linux-g++-64 \
+ || qmake als-controller.pro -r -spec linux-g++
+ make
+}
+
+package() {
+ cd $pkgname
+ install -Dm644 example/images/active.svg "$pkgdir"/usr/share/als-controller/example/images/active.svg
+ install -Dm644 example/images/inactive.svg "$pkgdir"/usr/share/als-controller/example/images/inactive.svg
+ install -Dm644 ../als-controller.service "$pkgdir"/usr/lib/systemd/system/als-controller.service
+ install -Dm755 example/switch.sh "$pkgdir"/usr/share/als-controller/example/switch.sh
+ install -Dm755 service/${pkgname} "$pkgdir"/usr/bin/${pkgname}
+}
diff --git a/als-controller.service b/als-controller.service
new file mode 100644
index 000000000000..10e725734e0b
--- /dev/null
+++ b/als-controller.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Ambient Light Sensor Daemon
+
+[Service]
+User=root
+Group=root
+PIDFile=/var/run/als-controller.pid
+ExecStart=/usr/bin/als-controller
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target