summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2015-06-12 11:01:17 +0200
committerlarchunix2015-06-12 11:33:11 +0200
commit20ccab460f5dc2c2bad6006e729a3276160cd734 (patch)
tree8aedacde656a1871f7e25348690045806be72286
downloadaur-20ccab460f5dc2c2bad6006e729a3276160cd734.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce143bcd32f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = alsa-tray
+ pkgdesc = A systray icon and a command line interface for setting the volume of the ALSA Mixers.
+ pkgver = 0.6
+ pkgrel = 2
+ url = http://software.flogisoft.com/alsa-tray/en/
+ arch = any
+ license = GPL3
+ depends = alsa-lib
+ depends = python2
+ depends = pygtk
+ depends = python2-pyalsaaudio
+ source = http://projects.flogisoft.com/alsa-tray/download/alsa-tray_0.6_src.tar.gz
+ md5sums = 59038e18afa94bcf08dc3bec3f19f23a
+
+pkgname = alsa-tray
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eec4d7e66e76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=alsa-tray
+pkgver=0.6
+pkgrel=2
+pkgdesc="A systray icon and a command line interface for setting the volume of the ALSA Mixers."
+arch=('any')
+url="http://software.flogisoft.com/$pkgname/en/"
+license=('GPL3')
+depends=('alsa-lib' 'python2' 'pygtk' 'python2-pyalsaaudio')
+source=("http://projects.flogisoft.com/$pkgname/download/${pkgname}_${pkgver}_src.tar.gz")
+md5sums=('59038e18afa94bcf08dc3bec3f19f23a')
+
+build () {
+ cd "$pkgname-$pkgver"
+ # modify the shebang line to force the use of /usr/bin/python2
+ # instead of /usr/bin/python
+ sed -e '1 s/$/2/' -i code/alsa_tray.py
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ ./install.sh --package "$pkgdir/"
+}
+
+# vim: set ft=sh ts=4 sw=4 noet: