summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2022-01-24 13:29:47 -0700
committerBrian Bidulock2022-01-24 13:29:47 -0700
commit9a3d81e25084384ac8e674cde082d97ee7c06237 (patch)
tree695d9eab23bdb861a1e3cc6614f29b26acb78864
parent562c7d3f6b0cc74e04b2c2f3770937bbdfa7ff05 (diff)
downloadaur-9a3d81e25084384ac8e674cde082d97ee7c06237.tar.gz
fix build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--strsignal.patch12
3 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e13dfb33ad69..74ee2b1728a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alsamixergui
pkgdesc = FLTK based mixer program for use with ALSA.
pkgver = 0.9.0rc2
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/LaraCraft304/alsamixergui
arch = i686
arch = x86_64
@@ -10,12 +10,13 @@ pkgbase = alsamixergui
depends = alsa-lib
source = http://ftp.de.debian.org/debian/pool/main/a/alsamixergui/alsamixergui_0.9.0rc2-1.orig.tar.gz
source = http://ftp.de.debian.org/debian/pool/main/a/alsamixergui/alsamixergui_0.9.0rc2-1-9.1.diff.gz
+ source = strsignal.patch
source = alsamixergui.desktop
source = alsamixergui.xpm
md5sums = af942a41b81ba27e2e4d0a1e1ab0decb
md5sums = 957c643604cc537eb547b9c7978d476d
+ md5sums = ff44a5223efec322a11c9e9ac29902cb
md5sums = 723f64293c24a7283d3d4b3dca442958
md5sums = ac46a80f8f5ea954e4dd70ef806d1374
pkgname = alsamixergui
-
diff --git a/PKGBUILD b/PKGBUILD
index 4e20e3e64d82..545e7af18e38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Lara Maia <lara@craft.net.br>
pkgname=alsamixergui
pkgver=0.9.0rc2
-pkgrel=5
+pkgrel=6
pkgdesc="FLTK based mixer program for use with ALSA."
arch=('i686' 'x86_64')
url='https://github.com/LaraCraft304/alsamixergui'
@@ -11,10 +11,12 @@ depends=('fltk' 'alsa-lib')
#source=('https://github.com/LaraCraft304/alsamixergui/archive/0.9.1.tar.gz'
source=("http://ftp.de.debian.org/debian/pool/main/a/${pkgname}/${pkgname}_${pkgver}-1.orig.tar.gz"
"http://ftp.de.debian.org/debian/pool/main/a/${pkgname}/${pkgname}_${pkgver}-1-9.1.diff.gz"
+ strsignal.patch
"${pkgname}.desktop"
"${pkgname}.xpm")
md5sums=('af942a41b81ba27e2e4d0a1e1ab0decb'
'957c643604cc537eb547b9c7978d476d'
+ 'ff44a5223efec322a11c9e9ac29902cb'
'723f64293c24a7283d3d4b3dca442958'
'ac46a80f8f5ea954e4dd70ef806d1374')
@@ -23,6 +25,7 @@ prepare() {
gzip -dc ${pkgname}_${pkgver}-1-9.1.diff.gz > ${pkgname}_${pkgver}-1-9.1.diff
cd ${pkgname}-$pkgver-1.orig
patch -Np1 -b -z .orig -i ../${pkgname}_${pkgver}-1-9.1.diff
+ patch -Np2 -b -z .was -i ../strsignal.patch
chmod +x configure
}
diff --git a/strsignal.patch b/strsignal.patch
new file mode 100644
index 000000000000..999fc00b8e53
--- /dev/null
+++ b/strsignal.patch
@@ -0,0 +1,12 @@
+diff -up src/alsamixergui-0.9.0rc2-1.orig/src/alsamixer.cxx.was src/alsamixergui-0.9.0rc2-1.orig/src/alsamixer.cxx
+--- src/alsamixergui-0.9.0rc2-1.orig/src/alsamixer.cxx.was 2022-01-24 13:24:15.190000000 -0700
++++ src/alsamixergui-0.9.0rc2-1.orig/src/alsamixer.cxx 2022-01-24 13:25:18.870000000 -0700
+@@ -2086,7 +2086,7 @@ static void
+ mixer_signal_handler (int signal)
+ {
+ if (signal != SIGSEGV)
+- mixer_abort (ERR_SIGNAL, sys_siglist[signal], 0);
++ mixer_abort (ERR_SIGNAL, strsignal(signal), 0);
+ else
+ {
+ fprintf (stderr, "\nSegmentation fault.\n");