summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-30 20:10:04 +0800
committerzxp198210052023-10-30 20:10:04 +0800
commit5d8400cf193fac72ac96e3fce18bfc7283cf564f (patch)
tree778a79a88f74bdc284325ccebcbc6e825899ad45
parentfd16b8c8f6505d40a1a3241b76dfd7b6374813fc (diff)
downloadaur-5d8400cf193fac72ac96e3fce18bfc7283cf564f.tar.gz
update to 0.16.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 30 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9dd1cf0a39e..133718ce3117 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alspotron-bin
pkgdesc = Shows the egg lyrics of the track, playing on Spotify / YouTube Music
- pkgver = 0.16.3
+ pkgver = 0.16.4
pkgrel = 1
url = https://github.com/organization/alspotron
arch = x86_64
@@ -14,7 +14,6 @@ pkgbase = alspotron-bin
depends = dbus
depends = alsa-lib
depends = nss
- depends = glibc
depends = nspr
depends = libxdamage
depends = cairo
@@ -26,12 +25,11 @@ pkgbase = alspotron-bin
depends = libxext
depends = libxfixes
depends = glib2
- depends = gcc-libs
depends = libx11
depends = mesa
- provides = alspotron=0.16.3
+ provides = alspotron=0.16.4
conflicts = alspotron
- source = alspotron-0.16.3.deb::https://github.com/organization/alspotron/releases/download/v0.16.3/alspotron_0.16.3_amd64.deb
- sha256sums = e91cdc45a3101a24d1fa1d04e6b8888af21026566c1527507f27ee5baf20b9de
+ source = alspotron-0.16.4.deb::https://github.com/organization/alspotron/releases/download/v0.16.4/alspotron_0.16.4_amd64.deb
+ sha256sums = 8bba356b0d504f6e9bfb3935d262d3aa76c47fe4ce8dde56a7ce040143f9a157
pkgname = alspotron-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7c34f314add6..9bcf1cce4431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=alspotron-bin
_pkgname=Alspotron
-pkgver=0.16.3
+pkgver=0.16.4
pkgrel=1
pkgdesc="Shows the egg lyrics of the track, playing on Spotify / YouTube Music"
arch=('x86_64')
@@ -9,10 +9,32 @@ url="https://github.com/organization/alspotron"
license=('Apache')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('libxrandr' 'at-spi2-core' 'libxkbcommon' 'pango' 'expat' 'java-runtime' 'dbus' 'alsa-lib' 'nss' 'glibc' 'nspr' \
- 'libxdamage' 'cairo' 'libxcomposite' 'libcups' 'libxcb' 'gtk3' 'libdrm' 'libxext' 'libxfixes' 'glib2' 'gcc-libs' 'libx11' 'mesa')
+depends=(
+ 'libxrandr'
+ 'at-spi2-core'
+ 'libxkbcommon'
+ 'pango'
+ 'expat'
+ 'java-runtime'
+ 'dbus'
+ 'alsa-lib'
+ 'nss'
+ 'nspr'
+ 'libxdamage'
+ 'cairo'
+ 'libxcomposite'
+ 'libcups'
+ 'libxcb'
+ 'gtk3'
+ 'libdrm'
+ 'libxext'
+ 'libxfixes'
+ 'glib2'
+ 'libx11'
+ 'mesa'
+)
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
-sha256sums=('e91cdc45a3101a24d1fa1d04e6b8888af21026566c1527507f27ee5baf20b9de')
+sha256sums=('8bba356b0d504f6e9bfb3935d262d3aa76c47fe4ce8dde56a7ce040143f9a157')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin} --no-sandbox|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"