summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-08 18:37:12 +0800
committerzxp198210052024-03-08 18:37:12 +0800
commite796738d46ab09aec108dd7462f9ad749ebaac6f (patch)
tree4f424bb265029b1abbd838c326bd1acf352079fc
parent90c6fa882f7cd1452c0938767fe2644f0aea0849 (diff)
downloadaur-e796738d46ab09aec108dd7462f9ad749ebaac6f.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--altarik-launcher.sh3
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c46bf86fb36..70f76acb74a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = altarik-launcher-bin
pkgdesc = A Minecraft custom launcher developped to launch the game with our own modpack.
pkgver = 2.1.6
- pkgrel = 1
+ pkgrel = 2
url = https://altarik.fr/
arch = x86_64
license = BSD-3-Clause
@@ -12,11 +12,11 @@ pkgbase = altarik-launcher-bin
conflicts = altarik-launcher
source = altarik-launcher-2.1.6.zip::https://github.com/AltarikMC/Launcher/releases/download/2.1.6/Altarik-Launcher-linux-x64-2.1.6.zip
source = LICENSE-2.1.6::https://raw.githubusercontent.com/AltarikMC/Launcher/2.1.6/LICENSE
- source = altarik-launcher-bin-2.1.6.ico::https://raw.githubusercontent.com/AltarikMC/Launcher/2.1.6/icon.ico
+ source = altarik-launcher-2.1.6.ico::https://raw.githubusercontent.com/AltarikMC/Launcher/2.1.6/icon.ico
source = altarik-launcher.sh
sha256sums = 1d11ebd18c78384ec2ad21c512d2036c2702a36c815033fe1c028a27e2a74ba4
sha256sums = 3a3a7d8474ca58bf2620f0a95275445faf654df7d4061afc209458b5fc8f8a2c
sha256sums = 5dbc783060b213ca39548ace82bbc9a2ffa35031b70728027a7a8e14dad2260a
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = altarik-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index 76eb01be1b65..9ec21e01698c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=altarik-launcher-bin
_pkgname=Altarik-Launcher
pkgver=2.1.6
_electronversion=28
-pkgrel=1
+pkgrel=2
pkgdesc="A Minecraft custom launcher developped to launch the game with our own modpack."
arch=('x86_64')
url="https://altarik.fr/"
@@ -21,19 +21,19 @@ makedepends=(
source=(
"${pkgname%-bin}-${pkgver}.zip::${_ghurl}/releases/download/${pkgver}/${_pkgname}-linux-x64-${pkgver}.zip"
"LICENSE-${pkgver}::https://raw.githubusercontent.com/AltarikMC/Launcher/${pkgver}/LICENSE"
- "${pkgname}-${pkgver}.ico::https://raw.githubusercontent.com/AltarikMC/Launcher/${pkgver}/icon.ico"
+ "${pkgname%-bin}-${pkgver}.ico::https://raw.githubusercontent.com/AltarikMC/Launcher/${pkgver}/icon.ico"
"${pkgname%-bin}.sh"
)
sha256sums=('1d11ebd18c78384ec2ad21c512d2036c2702a36c815033fe1c028a27e2a74ba4'
'3a3a7d8474ca58bf2620f0a95275445faf654df7d4061afc209458b5fc8f8a2c'
'5dbc783060b213ca39548ace82bbc9a2ffa35031b70728027a7a8e14dad2260a'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- convert "${srcdir}/${pkgname}-${pkgver}.ico" "${srcdir}/${pkgname%-bin}.png"
+ convert "${srcdir}/${pkgname%-bin}-${pkgver}.ico" "${srcdir}/${pkgname%-bin}.png"
gendesk -q -f -n --categories="Game" --name="${_pkgname}" --exec="${pkgname%-bin} %U"
}
package() {
diff --git a/altarik-launcher.sh b/altarik-launcher.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/altarik-launcher.sh
+++ b/altarik-launcher.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then