summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc6parmak2016-04-07 16:25:11 +0300
committerc6parmak2016-04-07 16:25:11 +0300
commit273564a1a5f20fa122ebf67712a92ba88dd94637 (patch)
tree047e411b3c96e62971e72ea3b1084ff3c0014153
downloadaur-273564a1a5f20fa122ebf67712a92ba88dd94637.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b289e211b17d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = alterant
+ pkgdesc = A self-contained dotfile manager and lightweight provisioning tool that supports encryption of sensitive data, multiline command execution, and a single file configuration for multiple machines.
+ pkgver = 26.d9b15e9
+ pkgrel = 1
+ url = https://github.com/autonomy/alterant
+ arch = x86
+ arch = x86_64
+ license = unknown
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = alterant
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..73652f3e03a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: c6parmak <can6parmak@gmail.com>
+pkgname=alterant
+pkgver=26.d9b15e9
+pkgrel=1
+pkgdesc="A self-contained dotfile manager and lightweight provisioning tool that supports encryption of sensitive data, multiline command execution, and a single file configuration for multiple machines."
+arch=('x86' 'x86_64')
+url="https://github.com/autonomy/alterant"
+license=('unknown')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+_gourl=github.com/autonomy/alterant
+
+pkgver() {
+ cd $srcdir/src/$_gourl
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ export GOPATH="$srcdir"
+ go get -d $_gourl
+}
+
+build() {
+ export GOPATH="$srcdir"
+ go get $_gourl
+}
+
+package() {
+ install -Dm755 "bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et:
+