summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2017-10-21 11:20:16 +0200
committerSebastian 'Swift Geek' Grzywna2017-10-21 11:21:44 +0200
commit7f52b96076ce85513396873389b7267e033cf50b (patch)
tree5d7fc511d85ead6e604cf8d0384280442756b4cf
downloadaur-7f52b96076ce85513396873389b7267e033cf50b.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--altermime-0.3.10-cflags.patch11
-rw-r--r--altermime-0.3.10-fprintf-compiler-error.patch45
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8eeb5a239c02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Oct 21 09:21:33 UTC 2017
+pkgbase = altermime
+ pkgdesc = MIME encoded email pack alteration tool
+ pkgver = 0.3.10
+ pkgrel = 0
+ url = http://www.pldaniels.com/altermime/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = BSD
+ depends = glibc
+ source = http://www.pldaniels.com/altermime/altermime-0.3.10.tar.gz
+ source = altermime-0.3.10-fprintf-compiler-error.patch
+ source = altermime-0.3.10-cflags.patch
+ md5sums = aaf0ad8029958a2dc6da3abb4dc178c2
+ md5sums = 4b8ce1a5878e595db6fdec8bb2bc3871
+ md5sums = 194efdd0f1cc15e0b8a3f7bbf8b2acd3
+
+pkgname = altermime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f6ad2602982
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Swift Geek
+pkgname=altermime
+pkgver=0.3.10
+pkgrel=0
+pkgdesc="MIME encoded email pack alteration tool"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="http://www.pldaniels.com/altermime/"
+license=('BSD')
+depends=('glibc')
+source=("http://www.pldaniels.com/altermime/altermime-${pkgver}.tar.gz"
+ "altermime-0.3.10-fprintf-compiler-error.patch"
+ "altermime-0.3.10-cflags.patch")
+md5sums=('aaf0ad8029958a2dc6da3abb4dc178c2'
+ '4b8ce1a5878e595db6fdec8bb2bc3871'
+ '194efdd0f1cc15e0b8a3f7bbf8b2acd3')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -Np0 -i "${srcdir}/altermime-0.3.10-fprintf-compiler-error.patch"
+ patch -Np0 -i "${srcdir}/altermime-0.3.10-cflags.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ install -d "$pkgdir/usr/bin/"
+ install -m 755 altermime "$pkgdir/usr/bin/"
+ install -d "$pkgdir/usr/share/licenses/altermime"
+ install -m 644 LICENCE "$pkgdir/usr/share/licenses/altermime"
+
+}
diff --git a/altermime-0.3.10-cflags.patch b/altermime-0.3.10-cflags.patch
new file mode 100644
index 000000000000..c18518ff4af4
--- /dev/null
+++ b/altermime-0.3.10-cflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2008-11-16 08:45:45.000000000 +0000
++++ Makefile 2011-02-11 16:33:17.777602478 +0000
+@@ -9,7 +9,7 @@
+ # opposite of a disclaimer.
+ #ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++#CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
diff --git a/altermime-0.3.10-fprintf-compiler-error.patch b/altermime-0.3.10-fprintf-compiler-error.patch
new file mode 100644
index 000000000000..ba19ebf40c06
--- /dev/null
+++ b/altermime-0.3.10-fprintf-compiler-error.patch
@@ -0,0 +1,45 @@
+--- qpe.c.orig 2008-11-16 08:45:45.000000000 +0000
++++ qpe.c 2008-11-23 12:06:08.000000000 +0000
+@@ -97,7 +97,7 @@
+ op+= strlen(paragraph);// +3; /** jump the output + =\r\n **/
+ out_remaining-= (strlen(paragraph)); // Was +3, updated to fix Outlook problems
+
+- QPD fprintf(stdout, "Soft break (%d + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
++ QPD fprintf(stdout, "Soft break (%Zd + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
+
+ /** reinitialize the paragraph **/
+ paragraph[0] = '\0';
+@@ -108,7 +108,7 @@
+ }
+
+ snprintf(pp, pp_remaining, "%s", charout);
+- QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%d result='%s'\n", charout, charout_size, pp_remaining, paragraph);
++ QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%Zd result='%s'\n", charout, charout_size, pp_remaining, paragraph);
+ pp += charout_size;
+ pp_remaining -= charout_size;
+ p++;
+@@ -149,13 +149,13 @@
+ out_size = in_size *3;
+ in_buffer = malloc( sizeof(char) *in_size +1);
+ if (in_buffer == NULL) {
+- QPD fprintf(stdout,"Error allocating %d bytes for input buffer\n", in_size);
++ QPD fprintf(stdout,"Error allocating %Zd bytes for input buffer\n", in_size);
+ return -1;
+ }
+
+ out_buffer = malloc( sizeof(char) *out_size *3 +1);
+ if (in_buffer == NULL) {
+- QPD fprintf(stdout,"Error allocating %d bytes for output buffer\n", out_size);
++ QPD fprintf(stdout,"Error allocating %Zd bytes for output buffer\n", out_size);
+ return -1;
+ }
+
+@@ -169,7 +169,7 @@
+ ** we segfault ;) **/
+ *(in_buffer +in_size) = '\0';
+
+- QPD fprintf(stdout,"file %s is loaded, size = %d\n", fname, in_size);
++ QPD fprintf(stdout,"file %s is loaded, size = %Zd\n", fname, in_size);
+
+ qp_encode( out_buffer, out_size, in_buffer, in_size );
+