summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2020-02-10 10:09:26 +0100
committerFélix Piédallu2020-02-10 10:09:26 +0100
commitde3a1135f46462fb08a93f36337a1e199a44db50 (patch)
treecf5c784415e9c4fedf8d367b677897e013cf1465
parent1146708e3511baf82ee302a3725f922eb68387e0 (diff)
downloadaur-de3a1135f46462fb08a93f36337a1e199a44db50.tar.gz
Fix installation
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD42
2 files changed, 28 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f23b986a1e0..a84c0b0763d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = altium2kicad-git
pkgdesc = Altium to KiCad converter for PCB and schematics
pkgver = r219.f7e739f
- pkgrel = 1
+ pkgrel = 4
url = https://github.com/thesourcerer8/altium2kicad
arch = i686
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = altium2kicad-git
arch = armv7h
license = AGPL3
depends = perl
+ conflicts = perl-math-bezier
source = git+https://github.com/thesourcerer8/altium2kicad
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 145947248804..669f4ee138f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=altium2kicad
pkgname=${_pkgname}-git
pkgver=r219.f7e739f
-pkgrel=1
+pkgrel=4
pkgdesc="Altium to KiCad converter for PCB and schematics"
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
url="https://github.com/thesourcerer8/altium2kicad"
@@ -19,6 +19,8 @@ sha256sums=(
'SKIP'
)
+conflicts=( 'perl-math-bezier' )
+
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -30,19 +32,27 @@ build() {
package () {
cd "${_pkgname}"
- install -d "$pkgdir/usr/share/altium2kicad"
- cp -R \
- "Math" \
- "Altium2KiCad.png" \
- "README.md" \
- "step2wrl.FCMacro" \
- "Tests.md" \
- "LICENSE" \
- "convertpcb.pl" "convertschema.pl" "unpack.pl" \
- "${pkgdir}/usr/share/altium2kicad"
-
-
- install -d "$pkgdir/usr/bin/"
- ln -s "/usr/share/altium2kicad/unpack.pl" "${pkgdir}/usr/bin/altium2kicad_unpack"
- chmod +x "${pkgdir}/usr/bin/altium2kicad_unpack"
+ # Install license file
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" \
+ "LICENSE"
+
+ # Install readmes
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" \
+ "README.md" "Tests.md"
+
+ # # Install Freecad macro
+ # install -Dm644 "step2wrl.FCMacro" \
+ # "${pkgdir}/usr/share/"
+
+ # Install Perl libraries
+ find "Math" -type f -exec \
+ install -Dm644 "{}" "${pkgdir}/usr/lib/perl5/5.30/vendor_perl/{}" \;
+
+ # Install executables
+ install -d "${pkgdir}/usr/bin"
+ for exe in "unpack" "convertpcb" "convertschema" ; do
+ install -Dm755 -t "${pkgdir}/usr/lib/altium2kicad" "${exe}.pl"
+ ln -s "/usr/lib/altium2kicad/${exe}.pl" "${pkgdir}/usr/bin/altium2kicad_${exe}"
+ done
+
}