summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Mazur2017-09-19 20:18:04 +0200
committerMaciej Mazur2017-09-19 20:24:55 +0200
commitd20314055f1383c8653fbf67f6654e9b7433bec1 (patch)
tree55e24a01a362f229e0fd9d3eb75f6ea51e88929b
downloadaur-d20314055f1383c8653fbf67f6654e9b7433bec1.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a8cacc3221d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = alttab-git
+ pkgdesc = The task switcher for minimalistic window managers or standalone X11 session
+ pkgver = v1.0.3.10.gf51b590
+ pkgrel = 1
+ url = https://github.com/sagb/alttab
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = autoconf
+ makedepends = automake
+ depends = libx11
+ depends = libxmu
+ depends = libxft
+ source = git+https://github.com/sagb/alttab.git#branch=master
+ sha1sums = SKIP
+
+pkgname = alttab-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5bc20463181f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/alttab-git-*.pkg.tar.xz
+/alttab
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd0808228628
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Maciej Mazur <mamciek@gmail.com>
+pkgname=alttab-git
+_name=alttab
+pkgver=v1.0.3.10.gf51b590
+pkgrel=1
+pkgdesc="The task switcher for minimalistic window managers or standalone X11 session"
+url="https://github.com/sagb/alttab"
+license=('GPL3')
+arch=('i686' 'x86_64')
+depends=('libx11' 'libxmu' 'libxft')
+makedepends=('autoconf' 'automake')
+source=("git+https://github.com/sagb/alttab.git#branch=master")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ git describe --tags |sed 's/-/./g'
+}
+
+build() {
+ pwd
+ ls -al
+ cd "$_name"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ pwd
+ ls -al
+ cd "$_name"
+ make DESTDIR="$pkgdir/" install
+}