summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-21 21:12:47 +0800
committerzxp198210052024-02-21 21:12:47 +0800
commit6d2528c77705726221304772b6fe434852607d16 (patch)
tree5725b4099b56fbb0009ff828e39b62bd57883f16
parentebd8b37bef359af3b1d84de95c8a4e47dd90415b (diff)
downloadaur-6d2528c77705726221304772b6fe434852607d16.tar.gz
update to 5.0.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--altus.sh6
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8fc2a773fb6..08f653fe16b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = altus
pkgdesc = Desktop client for WhatsApp Web with themes, notifications and multiple account support
- pkgver = 5.0.0
+ pkgver = 5.0.1
pkgrel = 1
url = https://github.com/amanharwara/altus
arch = any
@@ -13,9 +13,9 @@ pkgbase = altus
depends = electron28
depends = nodejs
conflicts = altus
- source = altus.git::git+https://github.com/amanharwara/altus.git#tag=5.0.0
+ source = altus.git::git+https://github.com/amanharwara/altus.git#tag=5.0.1
source = altus.sh
sha256sums = SKIP
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = altus
diff --git a/PKGBUILD b/PKGBUILD
index fd0ec41063d8..3e733ab7fb3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=altus
_pkgname=Altus
-pkgver=5.0.0
+pkgver=5.0.1
_electronversion=28
_nodeversion=18
pkgrel=1
@@ -26,7 +26,7 @@ source=(
"${pkgname}.sh"
)
sha256sums=('SKIP'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
@@ -36,10 +36,10 @@ _ensure_local_nvm() {
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname}.sh"
_ensure_local_nvm
- gendesk -q -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname} %U"
+ gendesk -q -f -n --categories="Network" --name="${_pkgname}" --exec="${pkgname} %U"
cd "${srcdir}/${pkgname}.git"
export npm_config_build_from_source=true
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
diff --git a/altus.sh b/altus.sh
index 0d20cddc70ca..f9ced1432cfc 100644
--- a/altus.sh
+++ b/altus.sh
@@ -1,14 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file