summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-04 15:27:28 +0800
committerzxp198210052023-07-04 15:27:28 +0800
commit870e5f2eb1faebc655b5930d787bc6be101644a6 (patch)
tree5dd2d16286d26e130956635d822fb73edcf3b089
downloadaur-870e5f2eb1faebc655b5930d787bc6be101644a6.tar.gz
first release
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD26
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16b339425231
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = altus
+ pkgdesc = Desktop client for WhatsApp Web with themes, notifications and multiple account support
+ pkgver = 4.8.6
+ pkgrel = 1
+ url = https://github.com/amanharwara/altus
+ arch = any
+ license = GPL3
+ makedepends = yarn
+ makedepends = electron
+ makedepends = gendesk
+ depends = pango
+ depends = glib2
+ depends = libxext
+ depends = alsa-lib
+ depends = libxcomposite
+ depends = libxcb
+ depends = libdrm
+ depends = libcups
+ depends = at-spi2-core
+ depends = libxrandr
+ depends = dbus
+ depends = libxkbcommon
+ depends = libx11
+ depends = gcc-libs
+ depends = cairo
+ depends = nspr
+ depends = gtk3
+ depends = nss
+ depends = expat
+ depends = mesa
+ depends = libxfixes
+ depends = libxdamage
+ depends = glibc
+ conflicts = altus
+ conflicts = altus-appimage
+ source = altus-4.8.6.tar.gz::https://github.com/amanharwara/altus/archive/refs/tags/4.8.6.tar.gz
+ sha256sums = ca5cb6f78df1a04beb1113d152171db8d2bab7d41d65658ff511af4de9dc0171
+
+pkgname = altus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d82af76f82a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="altus"
+pkgver=4.8.6
+pkgrel=1
+pkgdesc="Desktop client for WhatsApp Web with themes, notifications and multiple account support"
+arch=('any')
+url="https://github.com/amanharwara/altus"
+license=('GPL3')
+conflicts=("${pkgname}" "${pkgname}-appimage")
+depends=('pango' 'glib2' 'libxext' 'alsa-lib' 'libxcomposite' 'libxcb' 'libdrm' 'libcups' 'at-spi2-core' 'libxrandr' 'dbus' 'libxkbcommon' \
+ 'libx11' 'gcc-libs' 'cairo' 'nspr' 'gtk3' 'nss' 'expat' 'mesa' 'libxfixes' 'libxdamage' 'glibc')
+makedepends=('yarn' 'electron' 'gendesk')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('ca5cb6f78df1a04beb1113d152171db8d2bab7d41d65658ff511af4de9dc0171')
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ yarn install && yarn build
+}
+package() {
+ install -Dm755 -d "${pkgdir}/opt/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-${pkgver}/dist/linux-unpacked/"* "${pkgdir}/opt/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/public/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ gendesk -f --icon "${pkgname}" --categories "Network" --name "Altus" --exec "/opt/${pkgname%}/${pkgname} %U"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file