summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuhammad Al-Habib Ouadhour2018-08-10 14:00:35 +0100
committerMuhammad Al-Habib Ouadhour2018-08-10 14:00:35 +0100
commit998dd1b80d8223a2c750894d8a9f5714a5a3be2e (patch)
tree804bad4cf8a48e48e2625f100cfca76a7185042a
downloadaur-998dd1b80d8223a2c750894d8a9f5714a5a3be2e.tar.gz
First commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
-rwxr-xr-xalun.install18
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1aaf9ec8e1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = alun
+ pkgdesc = A CLI tool that notify the user when there is an update, excluding AUR
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/HOuadhour/alun
+ install = alun.install
+ arch = any
+ license = GPL3
+ depends = cronie
+ depends = pacman-contrib
+ depends = libnotify
+ depends = python
+ depends = pacman
+ optdepends = dunst: get notification on i3 WM
+ backup = etc/alun/conf.py
+ backup = etc/alun/crontab
+ source = https://github.com/HOuadhour/alun/releases/download/v1.0/alun-1.0.tar.gz
+ source = https://github.com/HOuadhour/alun/releases/download/v1.0/alun-1.0.tar.gz.sig
+ validpgpkeys = 6481A7A3E66A3AA39D0DD7302A60AB408C14BF70
+ sha256sums = 94ca3f986166333eb33de22c383ece67870c68de552a6da5a171a81e1f212100
+ sha256sums = 75f72a9303b07875996e4a69d29510939fc83c05a89349865ede6ef0a632300e
+
+pkgname = alun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00e471ef7a86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Muhammad Al-Habib Ouadhour <HOuadhour@yandex.com>
+
+pkgname=alun
+pkgver=1.0
+pkgrel=1
+pkgdesc="A CLI tool that notify the user when there is an update, excluding AUR"
+arch=('any')
+url="https://github.com/HOuadhour/alun"
+license=('GPL3')
+depends=('cronie' 'pacman-contrib' 'libnotify' 'python' 'pacman')
+optdepends=('dunst: get notification on i3 WM')
+backup=('etc/alun/conf.py' 'etc/alun/crontab')
+install=$pkgname.install
+source=(
+"https://github.com/HOuadhour/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+"https://github.com/HOuadhour/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.sig"
+)
+sha256sums=(
+'94ca3f986166333eb33de22c383ece67870c68de552a6da5a171a81e1f212100'
+'75f72a9303b07875996e4a69d29510939fc83c05a89349865ede6ef0a632300e'
+)
+validpgpkeys=('6481A7A3E66A3AA39D0DD7302A60AB408C14BF70')
+
+package() {
+ cd $pkgdir
+ tar -xf $srcdir/$pkgname-$pkgver.tar.gz
+}
diff --git a/alun.install b/alun.install
new file mode 100755
index 000000000000..ed501179aae2
--- /dev/null
+++ b/alun.install
@@ -0,0 +1,18 @@
+post_install() {
+ # enable cronie service if it's not enabled
+ systemctl is-enabled cronie > /dev/null || sudo systemctl enable cronie
+ # start cronie service if it's not started
+ systemctl is-active cronie > /dev/null || sudo systemctl start cronie
+ # create the crontab file
+ tput setaf 196
+ echo "==> Add the following line to your crontab file by running."
+ echo "$ crontab -e"
+ echo "*/30 * * * * env DISPLAY=:0 /usr/bin/alun"
+ echo "==> Run this command if you don't have a crontab file"
+ echo "$ crontab /etc/alun/crontab"
+ tput sgr0
+}
+
+post_upgrade() {
+ post_install
+}